03 r6 rough idle - Yamaha R6 Forum: YZF-R6 Forums
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 27 (permalink) Old 02-17-2010, 09:07 PM Thread Starter
Just made this great wheelie.. did you see it?!
 
peter123's Avatar
 
Join Date: Feb 2010
Location: Western MA
Posts: 61
Bike: '03 R6(sold), 2005 r1
03 r6 rough idle

hi im new to this forum and also new with bikes. I bought my r6 last summer with about 6k miles and it was running great. However a month or so into the season it started having idle problems. The idle cut in and out and it got so low that sometimes the engine would just die. so i had to turn up the idle a bit to like 1800, but it would still sometimes cut in and out. And it didnt just end there, it also, maybe 3 or 4 times the whole season while riding would just die when i pulled in the clutch and when i let go rpms would go back, it would also back fire really bad when this happened. Also when it would idle bad i would turn off the bike and put the power comander in program mode and it would idle fine, and sometimes come back but sometimes not. Could it be a faulty power commander? or maybe the coils? i still have to check whether i got the bad densos or not. And one more thing while riding, keeping the rpms steady at like 5k, the rpms sometimes drop a bit then go back up causing a very tiny jerk.
well im determined to fix this problem before i start riding again so any suggestions will be much appreciated.
thanks
peter123 is offline  
Sponsored Links
Advertisement
 
post #2 of 27 (permalink) Old 02-17-2010, 10:22 PM
UR B-hind Da 8 Ball
 
8Ball's Avatar
 
Join Date: Jun 2004
Location: East TN
Posts: 4,954
Bike: '03 R6, XR400, V-Star
Re: 03 r6 rough idle

Sounds like coils to me. I did have a problem with a PowerCommander III, the bike would shut off sometimes when decelerating into a turn around 10K rpm. But DynoJet replaced the unit and I've had no problems since. From your description, it sounds like you have a PC V, correct? If so, that is probably not your issue, unless you have a bad connection in the PC wiring harness.



I find a Soap Box comes in handy to get on my High Horse!
8Ball is offline  
post #3 of 27 (permalink) Old 02-18-2010, 07:07 AM Thread Starter
Just made this great wheelie.. did you see it?!
 
peter123's Avatar
 
Join Date: Feb 2010
Location: Western MA
Posts: 61
Bike: '03 R6(sold), 2005 r1
Re: 03 r6 rough idle

its a power commander III usb. Do you know if the coils would still be covered by that recall if i have the densos
peter123 is offline  
post #4 of 27 (permalink) Old 02-19-2010, 09:21 AM
I eat my R6
 
yamaguy's Avatar
 
Join Date: Oct 2009
Location: Louisiana
Posts: 160
Bike: pearl white zx10r
Re: 03 r6 rough idle

Your yamaha dealer should change them out for free. I had the same problem with my bike looked at the coils and had densos. There was also a recall on the front sprocket nut if i remember correctly. I had to pay for new plugs though, it was like $40. Hope this helps.
yamaguy is offline  
post #5 of 27 (permalink) Old 02-19-2010, 12:11 PM
.......
 
Join Date: May 2004
Location: Cincinnati
Posts: 7,347
Bike: 03 R6
Images: 2
Re: 03 r6 rough idle

sounds more like a bad throttle position sensor the 03 and 04 was plagued with.
they are pretty expensive. over $100. and just because it tests good doesn't mean it isn't bad. my buddies tests just fine but we swapped it out with mine and his bike ran perfect.

his was randomly stalling.
blue03r6 is offline  
post #6 of 27 (permalink) Old 02-22-2010, 06:56 PM
Just made this great wheelie.. did you see it?!
 
natedawgg94's Avatar
 
Join Date: Feb 2010
Location: Ohatchee, AL
Posts: 36
Bike: just picked up a 03' R6
Re: 03 r6 rough idle

mine seems to be the same at idle just kinda loading up but once you take it down the road it clears up. i just got the bike about 2 weeks ago weather has been kinda crappy so haven't had a chance to ride much. as far as mods it has a yoshi pipe and k&n filter as far as i know. new to bikes but work on cars a lot so shoot me some stuff to look far. can u take and clean the maf sensor on these bikes like u can on a car??? also thought maybe since the guy just has recharged the filter maybe he put to much oil on it???/ any help would be great

2003 yamaha R6 with frame sliders, k&n filter, and yoshi full exhaust and carbon fiber pipe, and power commander just got here
natedawgg94 is offline  
post #7 of 27 (permalink) Old 02-24-2010, 09:24 AM
hhhhmmmmm
 
Join Date: Feb 2010
Location: keene nh
Posts: 87
Bike: 06 r6
Re: 03 r6 rough idle

check to see what coils youve got.... you can still get them covered but you need to call yamaha and get an approval code to bring to the dealer (i had to do this last summer)

also as everyone has said there is a known issue with the tps and there is a monitor in the self diagnostic section of the gauge cluster. the FSM will tell u how to find it.

im a master tech with a full shop at my house in keene nh (may not be too far from u) if you need any help just pm me and bring the bike up

I walk tha corner to tha rubble that used to be a library,
Line up' to the mind cemetery now
tech1234 is offline  
post #8 of 27 (permalink) Old 02-24-2010, 07:41 PM
.......
 
Join Date: May 2004
Location: Cincinnati
Posts: 7,347
Bike: 03 R6
Images: 2
Re: 03 r6 rough idle

Quote:
Originally Posted by natedawgg94 View Post
mine seems to be the same at idle just kinda loading up but once you take it down the road it clears up. i just got the bike about 2 weeks ago weather has been kinda crappy so haven't had a chance to ride much. as far as mods it has a yoshi pipe and k&n filter as far as i know. new to bikes but work on cars a lot so shoot me some stuff to look far. can u take and clean the maf sensor on these bikes like u can on a car??? also thought maybe since the guy just has recharged the filter maybe he put to much oil on it???/ any help would be great
there isn't a MAF on a bike.
they have 4 separate throttle bodies. it could just simply need a good synchronization.
the synch of the throttle bodies plays a big part of the good smooth idle.
with an aftermarket pipe they will fluctuate slightly at idle.(100-300rpm typically)
that's normal.

look at the top of the coils. if they are a light tan epoxy top without any sticker that's the mitsubishi coils that are the good ones.
the bad ones have a black epoxy top with a black and white sticker that says DENSO on it.







Last edited by blue03r6; 02-24-2010 at 07:45 PM.
blue03r6 is offline  
post #9 of 27 (permalink) Old 02-24-2010, 08:03 PM
Just made this great wheelie.. did you see it?!
 
natedawgg94's Avatar
 
Join Date: Feb 2010
Location: Ohatchee, AL
Posts: 36
Bike: just picked up a 03' R6
Re: 03 r6 rough idle

thanks i'll try to see what i have tomorrow after work.

2003 yamaha R6 with frame sliders, k&n filter, and yoshi full exhaust and carbon fiber pipe, and power commander just got here
natedawgg94 is offline  
post #10 of 27 (permalink) Old 02-25-2010, 11:14 AM
Just made this great wheelie.. did you see it?!
 
natedawgg94's Avatar
 
Join Date: Feb 2010
Location: Ohatchee, AL
Posts: 36
Bike: just picked up a 03' R6
Re: 03 r6 rough idle

well i just finished talking to the guy i got the bike from here at work and he said that the coils have been done about 5k miles ago. he had them done right after he got the bike. Also said the bike would do this in cold weather when he had it but once summer gets here it quits.

2003 yamaha R6 with frame sliders, k&n filter, and yoshi full exhaust and carbon fiber pipe, and power commander just got here
natedawgg94 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha R6 Forum: YZF-R6 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2002 R6 Idle Troubles? Irillus Garage / Mechanical Help 12 04-19-2011 01:28 PM
03 R6 doesn't idle high when cold Schrute Farms General Discussions 7 04-18-2009 08:22 AM
05 R6 idle problem Yazman Garage / Mechanical Help 3 04-10-2009 04:24 PM
04 R6 PC3 Sloppy Idle Khojima Garage / Mechanical Help 1 04-01-2009 06:42 AM
Random R6/GSXR parts, rearsets, takesoffs, new tires, ect... FastrnU Bike Parts For Sale 24 09-07-2008 01:57 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome