TPS Diagnostic Mode - Yamaha R6 Forum: YZF-R6 Forums
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 46 (permalink) Old 08-21-2011, 06:58 PM Thread Starter
Just made this great wheelie.. did you see it?!
 
Join Date: May 2010
Location: Distrito Federal, Mexico.
Posts: 83
Bike: Yamaha R6 2009
TPS Diagnostic Mode

Hi,

I tried to calibrate throttle position for my pcv+autotune like in this thread http://www.r6-forum.com/forums/showt...24#post2100524 so I followed the instructions entered into Diagnostic mode d01, twisted the throttle all the way and the max number that it reaches is 61, in his tutorial he mentions that the number should be close to 100. Is something wrong with my TPS?? Do I have to adjust something? What can I do?

Also in the PCV throttle Calibration window I don't see the voltage changing, only 0s, That isn't normal right??

*EDIT* without PCV everything seems fine in diagnostic mode


Thanks in advance.

Last edited by Hellerox; 10-03-2011 at 07:21 PM.
Hellerox is offline  
Sponsored Links
Advertisement
 
post #2 of 46 (permalink) Old 08-21-2011, 07:10 PM
I eat my R6
 
OhioYJ's Avatar
 
Join Date: Jun 2009
Posts: 2,818
Re: TPS Diagnostic Mode

You should see the voltage changing in the PCV software, if it's not thats a problem. With the bike running when you rev the motor do you see any change in the TPS reading in the PCV software?

You might need to clean the TPS sensor connections, or you may have a created a bad connection when you hooked into the TPS wire when installing the PCV.

07 R6, MJS Header, GYTR slip on, smog block offs, K&N, flashed ECU, PCV, AutoTune, -1/+2.
OhioYJ is offline  
post #3 of 46 (permalink) Old 08-22-2011, 09:31 AM
Just made this great wheelie.. did you see it?!
 
Join Date: Dec 2010
Location: Canton, OH
Posts: 42
Bike: 2005 R6
Re: TPS Diagnostic Mode

Yeah there is definitely something wrong there. I checked mine not too long ago just for the hell of it and it read 96 at WOT. There is walkthrough HERE on how to clean the TPS on the second gens, I imagine it is similar to the r6r. I would clean it and try to test the voltage to see if it fixes things before getting a new one.
Rossy is offline  
post #4 of 46 (permalink) Old 08-22-2011, 10:16 AM
I eat my R6
 
Matt_M's Avatar
 
Join Date: Apr 2011
Location: Jax FL
Posts: 763
Bike: 06 raven
Re: TPS Diagnostic Mode

i did this last week and after i was in the dia mode it didnt read full either but i turned the key off and redid it..the second time i did it i got to the dia mode and then hit select i believe and it took it to 001 and then i calibrated the tps and it read 100

Current Upgrades
M4 midpipe
Graves Block off plates
Termi slip on
Bazzaz ZFi & ZAFM
Dunlop Q2
Graves EXUP eliminator
BMC race filter
Woodcraft frame sliders
15T Driven front sprocket
ASV C5 levers
Matt_M is offline  
post #5 of 46 (permalink) Old 08-23-2011, 10:09 AM
Member
 
Join Date: Jan 2008
Location: Montreal, Canada
Posts: 228
Bike: '12 R6
Re: TPS Diagnostic Mode

You just need to adjust the angle at which your TPS is bolted on. Closed throttle should read 15-17, WOT should read 97-100.
dhanoon6 is offline  
post #6 of 46 (permalink) Old 08-23-2011, 10:20 AM
zomething different
 
r3x1mu5's Avatar
 
Join Date: Feb 2009
Location: CA
Posts: 8,430
Bike: 07 R6s
Re: TPS Diagnostic Mode

Quote:
Originally Posted by dhanoon6 View Post
You just need to adjust the angle at which your TPS is bolted on. Closed throttle should read 15-17, WOT should read 97-100.
mine read 17 96 last time i checked. is this bad? could i adjust something so it opens up more?

...if i don't make it home today, god bless. dot cheers
r3x1mu5 is offline  
post #7 of 46 (permalink) Old 08-23-2011, 12:21 PM
Member
 
Join Date: Jan 2008
Location: Montreal, Canada
Posts: 228
Bike: '12 R6
Re: TPS Diagnostic Mode

^ I actually have the same reading, i spent so much time fiddling with it trying to get it within spec but the best i could do was 17 96. You can always try to readjust it but I wouldn't worry about it.
dhanoon6 is offline  
post #8 of 46 (permalink) Old 08-23-2011, 01:11 PM
zomething different
 
r3x1mu5's Avatar
 
Join Date: Feb 2009
Location: CA
Posts: 8,430
Bike: 07 R6s
Re: TPS Diagnostic Mode

cool, thanks for the info.

...if i don't make it home today, god bless. dot cheers
r3x1mu5 is offline  
post #9 of 46 (permalink) Old 08-23-2011, 01:50 PM Thread Starter
Just made this great wheelie.. did you see it?!
 
Join Date: May 2010
Location: Distrito Federal, Mexico.
Posts: 83
Bike: Yamaha R6 2009
Re: TPS Diagnostic Mode

Quote:
Originally Posted by OhioYJ View Post
You should see the voltage changing in the PCV software, if it's not thats a problem. With the bike running when you rev the motor do you see any change in the TPS reading in the PCV software?

You might need to clean the TPS sensor connections, or you may have a created a bad connection when you hooked into the TPS wire when installing the PCV.
I didn't see it when I was trying to calibrate the PCV, but I do see RPM and throttle changing when the bike is on and I rev it.

I'm going to check the connections.
Hellerox is offline  
post #10 of 46 (permalink) Old 08-23-2011, 01:54 PM Thread Starter
Just made this great wheelie.. did you see it?!
 
Join Date: May 2010
Location: Distrito Federal, Mexico.
Posts: 83
Bike: Yamaha R6 2009
Re: TPS Diagnostic Mode

Quote:
Originally Posted by dhanoon6 View Post
You just need to adjust the angle at which your TPS is bolted on. Closed throttle should read 15-17, WOT should read 97-100.
Where is the TPS??


Quote:
Originally Posted by Matt_M View Post
i did this last week and after i was in the dia mode it didnt read full either but i turned the key off and redid it..the second time i did it i got to the dia mode and then hit select i believe and it took it to 001 and then i calibrated the tps and it read 100
I'll try this after work.


Thanks for all your responses.
Hellerox is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha R6 Forum: YZF-R6 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Diagnostic Mode for 2007 cluster? R6xxer Garage / Mechanical Help 6 07-03-2011 05:49 PM
Diagnostic Mode???? D33PU Garage / Mechanical Help 2 04-21-2008 08:58 PM
Diagnostic mode R6 2006 Anthony00 Garage / Mechanical Help 2 05-28-2007 09:08 AM
Diagnostic Mode - What does "CO" mean? 666 General Discussions 3 05-10-2007 02:19 AM
DIAGNOSTIC MODE from OEM Cluster... IWannaBoost General Discussions 4 03-16-2005 09:59 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome