Rough Idle? Please help 2010 R6 - Yamaha R6 Forum: YZF-R6 Forums
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 05-26-2019, 10:00 AM Thread Starter
My R6 eats me.
 
Join Date: May 2019
Posts: 8
Rough Idle? Please help 2010 R6

I posted a video on youtube link will be provided but just back story.. bought the bike 2 weeks ago has 3600 miles and its a 2010.. was sitting for like 2 years or more. Starts right up.. no issues dying on me at lights or anything. In the video im running 100 octane race gas but it was rough like this even with 93 in it. Idle seems a bit choppy and rough.. runs fine at higher rpms and has tons of power.. no hesitation which confirms its not a serious issue.. hopefully its an 02 sensor or some other sensor that needs to be cleaned... you guys have way more experience than I do.. Please help me out and check out the video... would love to hear some feedback!


To view links or images in this forum your post count must be 5 or greater. You currently have 0 posts.
Jfaris1222 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 05-26-2019, 10:02 AM Thread Starter
My R6 eats me.
 
Join Date: May 2019
Posts: 8
Re: Rough Idle? Please help 2010 R6


To view links or images in this forum your post count must be 5 or greater. You currently have 0 posts.
Jfaris1222 is offline  
post #3 of 7 (permalink) Old 05-26-2019, 01:46 PM
I eat my R6
 
Join Date: Jan 2016
Posts: 2,604
Bike: 2015 R1
Garage
Re: Rough Idle? Please help 2010 R6

well do you know if it has a tune? often when you change the exhaust the bike will idle funny like that without a proper map. also, this race gas you are using, i hope it doesn't have lead in it. or you will kill the O2 sensors and clog the catalytic converters in the headers.
now, I'm not sure what years did this but they put the converter inside the headers so you can't remove it without replacing the headers.
i'm not sure if the 2010 still did that or not. so just wait for someone else to respond about that. but if you are not using leaded race gas there is nothing to worry about.

also this may be able to be reduced by having the throttle bodies synchronized. but i'm betting it's just the exhaust. and possibly a dirty fuel injector from sitting. sitting bikes/cars isn't good for them unless the fuel system was drained.

Last edited by yamahacrazy; 05-26-2019 at 01:49 PM.
yamahacrazy is offline  
post #4 of 7 (permalink) Old 05-27-2019, 08:09 AM Thread Starter
My R6 eats me.
 
Join Date: May 2019
Posts: 8
Re: Rough Idle? Please help 2010 R6

Quote:
Originally Posted by yamahacrazy View Post
well do you know if it has a tune? often when you change the exhaust the bike will idle funny like that without a proper map. also, this race gas you are using, i hope it doesn't have lead in it. or you will kill the O2 sensors and clog the catalytic converters in the headers.
now, I'm not sure what years did this but they put the converter inside the headers so you can't remove it without replacing the headers.
i'm not sure if the 2010 still did that or not. so just wait for someone else to respond about that. but if you are not using leaded race gas there is nothing to worry about.

also this may be able to be reduced by having the throttle bodies synchronized. but i'm betting it's just the exhaust. and possibly a dirty fuel injector from sitting. sitting bikes/cars isn't good for them unless the fuel system was drained.

im not sure if it has a tune but even a slip on exhaust will mess with it like that? Also it has the cat in the headers for sure.. but sonoco 100octane race gas is unleaded...I read somewhere that oscillation of 100 or so RPM isnt a bad thing and most people have an even rougher idle. let me knows guys! please!
Jfaris1222 is offline  
post #5 of 7 (permalink) Old 05-28-2019, 04:58 PM
I eat my R6
 
Join Date: Jan 2016
Posts: 2,604
Bike: 2015 R1
Garage
Re: Rough Idle? Please help 2010 R6

Quote:
Originally Posted by Jfaris1222 View Post
im not sure if it has a tune but even a slip on exhaust will mess with it like that? Also it has the cat in the headers for sure.. but sonoco 100octane race gas is unleaded...I read somewhere that oscillation of 100 or so RPM isnt a bad thing and most people have an even rougher idle. let me knows guys! please!
yes it's pretty common to have it fluctuate like that from a slip on.
yamahacrazy is offline  
post #6 of 7 (permalink) Old 05-29-2019, 07:06 AM
My R6 eats me.
 
Join Date: Nov 2015
Posts: 1
Re: Rough Idle? Please help 2010 R6

My 2010 that I just sold sounded exactly the same as that. It is a little worse when cold but once warm itís barely noticeable.

Mine had the stock headers which had been decatted along with a Yoshi slip on.

Youíre fine.


Sent from my iPad using Tapatalk
Chekando is offline  
post #7 of 7 (permalink) Old 06-02-2019, 07:52 PM
Yamaha Blue
 
Join Date: Aug 2018
Posts: 18
Make sure your throttle bodies are synced
Etkinso is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha R6 Forum: YZF-R6 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2010 R6 Partout cc1084 Bike Parts For Sale 4 05-19-2019 02:26 PM
Rough idle R6 2008 Arcibal General Discussions 16 03-26-2019 01:49 PM
2006 r6 idle jumping when warm datr6guy Garage / Mechanical Help 0 02-18-2019 06:21 PM
2003 R6 low idle after bike heats up Luke Dixon Garage / Mechanical Help 8 12-19-2018 12:00 PM
06 r6 rough idle and bogging/stuttering at takeoff ccsencsits Garage / Mechanical Help 0 07-15-2018 03:06 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome