2006 R6 FTECU Quickshift - Yamaha R6 Forum: YZF-R6 Forums
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 06-05-2019, 07:04 AM Thread Starter
My R6 eats me.
 
Join Date: May 2019
Posts: 18
2006 R6 FTECU Quickshift

Had my ECU flashed by 2 Wheel Dynoworks recently, and sprung for the FTECU quickshifter from them. Installation was pretty easy, no issues there.

The lower gears (1, 2, 3) all shift consistently with no problem. Occasionally 4th won't work, sometimes 5th, and now sometimes 6th. It is not related to RPM, it does it at all RPM ranges, and at all throttle openings. I have put an RF choke on the QS harness in hopes it was an interference issue, but no luck. The shift arms are parallel, so the linkage arm length is correct.

I have been reading about the newer QS problems people have been having, is this common on the older 2006 as well?
IssyR6 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha R6 Forum: YZF-R6 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome