2017 R6 wont start Please Help! - Yamaha R6 Forum: YZF-R6 Forums
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 04-22-2019, 06:27 PM Thread Starter
My R6 eats me.
 
Join Date: Apr 2019
Location: San diego
Posts: 8
Hello Everyone, thanks so much for contributing to this forum its a great resource for people like me. Hopefully you guys can help me out with this issue.

Im helping a buddy get his R6 back in working order after it was laid down on the left hand side. The bike sat outside for about 6 months, and hasn't ran since the crash The crash broke the left handle off, but only bent the clutch lever and the switch seems to be ok. The stator cover was replaced, and gas tank (filled the new tank with about 1.5 gallons of 91) along with some other various damaged parts. Got the bike all back together, and now it wont start, I replaced the 50amp main fuse which was blown, and the ETV (7.5) fuse was blown also. The rest of the fuses on the bike looked ok. Fuel pump is making normal sound when the ignition key is turned on also. After cranking the bike for a while, I was able to get the bike to turn on for about 30 seconds - 3 times in a row, sounded like the idle was pretty low, but when i tried to rev the throttle, the bike would bog and turn off. After those few times barley starting it just cranks and wont fire again. I changed the spark plugs, and verified there is spark on all four cylinders, not sure why it wont start. I read on here that you need to have a diagnostic module to pull the codes which I dont have, and would like to avoid taking it to the stealer to get the codes out of it. Could i be the clutch switch? Kickstand switch? Coils? fuel injectors? Any help is much appreciated to get this thing going again.

If you need more info, please let me know.....

Last edited by Brent Mesnick; 04-22-2019 at 09:06 PM. Reason: There’s only 7000 miles on the bike also.
Brent Mesnick is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 04-22-2019, 06:49 PM
Just made this great wheelie.. did you see it?!
 
Peanut_EOD's Avatar
 
Join Date: Sep 2018
Location: Atlanta, Georgia
Posts: 48
Bike: 2018 YZF-R6 Blue
Re: 2017 R6 wont start Please Help!

Where are you?


Sent from my iPhone using Tapatalk
Peanut_EOD is offline  
post #3 of 13 (permalink) Old 04-22-2019, 06:50 PM
I eat my R6
 
Join Date: Aug 2017
Posts: 284
Re: 2017 R6 wont start Please Help!

Is the tip over sensor in the right orientation?

Last edited by El Duder; 04-22-2019 at 06:53 PM.
El Duder is offline  
 
post #4 of 13 (permalink) Old 04-22-2019, 06:52 PM
Just made this great wheelie.. did you see it?!
 
Peanut_EOD's Avatar
 
Join Date: Sep 2018
Location: Atlanta, Georgia
Posts: 48
Bike: 2018 YZF-R6 Blue
Re: 2017 R6 wont start Please Help!

Quote:
Originally Posted by El Duder View Post
Is the tip over sensor is the right orientation?


That was my first thought, but the fact that it started at all made me think otherwise.


Sent from my iPhone using Tapatalk
Peanut_EOD is offline  
post #5 of 13 (permalink) Old 04-22-2019, 07:03 PM Thread Starter
My R6 eats me.
 
Join Date: Apr 2019
Location: San diego
Posts: 8
I’m located in San Diego, we got quite a bit of rain over the winter, and the bike was sitting out side, but all of the electrical connections are in good shape, especially the battery connections. And I thought it may be the tip over sensor also, but it did start a couple times. Also, all of the plugs were wet when I pulled them out to change them.
Brent Mesnick is offline  
post #6 of 13 (permalink) Old 04-22-2019, 09:53 PM Thread Starter
My R6 eats me.
 
Join Date: Apr 2019
Location: San diego
Posts: 8
Thinking about getting the 4-pin to odb2 connector so I can pull the codes, I’m having trouble finding the list of codes for the 2017 R6.... anyone have a list of the codes so when I pull them I can try to fix the issue?
Brent Mesnick is offline  
post #7 of 13 (permalink) Old 04-23-2019, 05:59 AM
Just made this great wheelie.. did you see it?!
 
Peanut_EOD's Avatar
 
Join Date: Sep 2018
Location: Atlanta, Georgia
Posts: 48
Bike: 2018 YZF-R6 Blue
Re: 2017 R6 wont start Please Help!

Iím pretty sure theyíre the same as automotive codes for cars.


Sent from my iPhone using Tapatalk
Peanut_EOD is offline  
post #8 of 13 (permalink) Old 04-23-2019, 09:11 AM Thread Starter
My R6 eats me.
 
Join Date: Apr 2019
Location: San diego
Posts: 8
Ok thanks I was thinking I could use the code matrix from an older model R6. Hopefully someone else chimes in on a potential issue, I hope it’s something simple.
Brent Mesnick is offline  
post #9 of 13 (permalink) Old 04-24-2019, 08:35 AM
My R6 eats me.
 
Join Date: Oct 2014
Location: Eu, Austria
Posts: 7
Bike: r6 5eb
Re: 2017 R6 wont start Please Help!

Try to start in 2nd gear on really long hill!

This helped me when bike was sitting for a long time
To view links or images in this forum your post count must be 5 or greater. You currently have 0 posts.
Arrr is offline  
post #10 of 13 (permalink) Old 04-25-2019, 12:02 AM Thread Starter
My R6 eats me.
 
Join Date: Apr 2019
Location: San diego
Posts: 8
I’ve been doing some reading, maybe some one can chime in. It’s possible the fuel pump may have been damaged in the crash, and even though its priming, it may not be putting enough fuel in the engine. Anyone know a way to test the fuel pump, or have a cheap way to build a pressure gauge without buying the $250 yahama pressure gauge adapter? Would the lack of fuel pressure be a reason why the bike started, a couple times and won’t start again?
Brent Mesnick is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha R6 Forum: YZF-R6 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2011 r6 cold start is very hard!!! MJ69 Garage / Mechanical Help 6 10-20-2018 11:50 PM
2002 R6 no start after transmission repair BenPretty Garage / Mechanical Help 7 10-08-2018 05:54 PM
R6 2017 speedo meter US can fit UK? Rewki333 Garage / Mechanical Help 0 09-05-2018 04:47 PM
2008 R6 Won't Start R6trackrider Garage / Mechanical Help 7 08-30-2018 03:07 PM
09 r6 was lide down an wont start sik505 R6-forum.com Site Help and Suggestions 1 06-25-2018 10:57 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome