99 R6 Won't Go past 10K RPMs - Yamaha R6 Forum: YZF-R6 Forums
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 07-09-2015, 02:32 PM Thread Starter
SMP 420
 
Join Date: Jul 2015
Location: Knoxville, TN
Posts: 5
Angry 99 R6 Won't Go past 10K RPMs

I have a 1999 R6 that is acting up. When the bike is in Neutral it runs fine no issues and I can rev the bike up to red line with no issues. The problem comes when you go to ride it in first gear I can get it up to about 12K rpms and in second gear I can get up to 10K RPM in all the remaining gears it will not go past 8K rpms.Under hard acceleration it is like hitting a brick wall and I can keep the throttle wide open and it will just stutter along at those rpms and cruise down the road but won't produce anymore power. I can back off the throttle and ease it back up and sometimes it will climb to a higher rpm but not much higher. Has anyone else dealt with something similar?


Here is what I have tried so far with no luck.

Changed fuel filter, fuel pump, oil and spark plugs. I have cleaned the air filter, cleaned the carbs, jetted the carbs, I've tested the charging system with a voltmeter, I've tried running the bike with the headlights disconnected, I have looked for pinched air or fuel lines. I have checked the headers by spraying with water and all cylinders are firing, I have checked the coils with voltmeter and they tested alright but I had an extra set of coils in another running bike so I swapped them out for shits and giggles. I'm sure I am forgetting something but even after all of this there has been no significant or noticeable changes!
To view links or images in this forum your post count must be 5 or greater. You currently have 0 posts.

To view links or images in this forum your post count must be 5 or greater. You currently have 0 posts.
I'm running out of ideas and I really want to get this bike running!
CBRscorpio13 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 07-09-2015, 02:44 PM
Parts Pimp
 
ChiefSmokeDawg's Avatar
 
Join Date: Sep 2009
Location: JerZ
Posts: 26,451
Bike: 2002 R6, 2008 R6
Re: 99 R6 Won't Go past 10K RPMs

The slides in the carbs are probably not lifting. I can't imagine the jetting being so off that it stops at 8k. But from 8k to redline the slides are supposed to be up fully and allows you to keep ripping.

You should lift off the black caps on the carbs and inspect the diaphram that is attached to the slides. If any kind of cleaner or gas has gotten onto them, they are probably destroyed. In the corner of each one where it sits under the cap is a small brass pin. that has an o ring around it too I believe. This is what creates the vacuum to lift them.

Get back inside the carbs and target your search at these slides and the diaphragms.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Ask about:-STAHLBUS- -WOODCRAFT- -MOTUL- -FERODO- -BRAKE TECH- -BMC- -Battery Tender-LEO VINCE- -NGK- -EBC- -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
-
ChiefSmokeDawg is offline  
post #3 of 10 (permalink) Old 07-09-2015, 05:41 PM Thread Starter
SMP 420
 
Join Date: Jul 2015
Location: Knoxville, TN
Posts: 5
Re: 99 R6 Won't Go past 10K RPMs

Alright I will take another look at the carbs tomorrow. Do you think adjusting the needle heights could help fix the issue?
CBRscorpio13 is offline  
 
post #4 of 10 (permalink) Old 07-10-2015, 06:45 AM
Parts Pimp
 
ChiefSmokeDawg's Avatar
 
Join Date: Sep 2009
Location: JerZ
Posts: 26,451
Bike: 2002 R6, 2008 R6
Re: 99 R6 Won't Go past 10K RPMs

Quote:
Originally Posted by CBRscorpio13 View Post
Alright I will take another look at the carbs tomorrow. Do you think adjusting the needle heights could help fix the issue?

If everything looks good with the slides then yea I would adjust the needle height for sure. The issue is slide related. Whether they just aren't lifting at all or if the needles are so off that when they do lift the bike bigs or goes super lean.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Ask about:-STAHLBUS- -WOODCRAFT- -MOTUL- -FERODO- -BRAKE TECH- -BMC- -Battery Tender-LEO VINCE- -NGK- -EBC- -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
-
ChiefSmokeDawg is offline  
post #5 of 10 (permalink) Old 07-10-2015, 01:58 PM Thread Starter
SMP 420
 
Join Date: Jul 2015
Location: Knoxville, TN
Posts: 5
Re: 99 R6 Won't Go past 10K RPMs

Alright after checking the slides I found that the 3rd one from the left is not opening up all the way it is only opening up about 3/4 of the way. I am going to fix that and test it again and if it is still acting up adjust the needle height. I'll let you know how it goes.

Thanks
CBRscorpio13 is offline  
post #6 of 10 (permalink) Old 07-12-2015, 08:18 AM
Parts Pimp
 
ChiefSmokeDawg's Avatar
 
Join Date: Sep 2009
Location: JerZ
Posts: 26,451
Bike: 2002 R6, 2008 R6
Re: 99 R6 Won't Go past 10K RPMs

Quote:
Originally Posted by CBRscorpio13 View Post
Alright after checking the slides I found that the 3rd one from the left is not opening up all the way it is only opening up about 3/4 of the way. I am going to fix that and test it again and if it is still acting up adjust the needle height. I'll let you know how it goes.

Thanks

To view links or images in this forum your post count must be 5 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Ask about:-STAHLBUS- -WOODCRAFT- -MOTUL- -FERODO- -BRAKE TECH- -BMC- -Battery Tender-LEO VINCE- -NGK- -EBC- -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
-
ChiefSmokeDawg is offline  
post #7 of 10 (permalink) Old 07-13-2015, 12:46 PM Thread Starter
SMP 420
 
Join Date: Jul 2015
Location: Knoxville, TN
Posts: 5
Re: 99 R6 Won't Go past 10K RPMs

Alright I fixed the slides they are all working properly and adjusted the needles from the second slot to the second to last slot and the bike is still doing the same thing. Plus all the needles were already shimmed. So back to square one on that. I did notice that the idle was a little rough after adjusting it.
CBRscorpio13 is offline  
post #8 of 10 (permalink) Old 07-15-2015, 07:54 AM Thread Starter
SMP 420
 
Join Date: Jul 2015
Location: Knoxville, TN
Posts: 5
Re: 99 R6 Won't Go past 10K RPMs

Anyone have any other ideas?
CBRscorpio13 is offline  
post #9 of 10 (permalink) Old 09-07-2019, 03:27 PM
My R6 eats me.
 
Join Date: Sep 2019
Posts: 1
Having same issue!! Tried everything has anyone solved this problem????
Jared Havell is offline  
post #10 of 10 (permalink) Old 09-11-2019, 12:46 AM
My R6 eats me.
 
Join Date: Mar 2017
Posts: 15
Re: 99 R6 Won't Go past 10K RPMs

Maybe some coil make trouble?
Is the engine don't reving up - without any special "blipping" noise? It sounds like leaning out?
Or do you hear some bangs from the exhaust? (= ignition trouble)
Acki84 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha R6 Forum: YZF-R6 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 r6 won't hold idle and won't rev past 8000rpms JustChill27 Exhaust and fuel delivery 0 09-27-2014 12:54 PM
2005 r6 won't go past 6K rpms Merk_RR Garage / Mechanical Help 16 07-15-2013 02:47 PM
2005 R6 Won't rev past 8k rpms conwaymx Garage / Mechanical Help 4 05-07-2013 02:49 AM
r6 rpms slowwwwwww down at 10k! speech_less General Discussions 4 09-22-2010 08:02 AM
2000 R6 won't rev past 10k chubbster1uk Exhaust and fuel delivery 7 05-12-2005 07:18 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome