2007 R6 wont idle after rebuild - Yamaha R6 Forum: YZF-R6 Forums
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 08-29-2011, 06:23 PM Thread Starter
R6 for Life
 
Join Date: Apr 2011
Posts: 18
Bike: 03,06 and 07 R6's
2007 R6 wont idle after rebuild

Hey guys, so i picked up a crashed bike and rebuilt it for a new track bike.

It had a blown head gasket so i had the engine apart and replaced it, also installed a YEC ecu.

Now the bike seems to run well when i give it throttle, but it wont idle at all. if i back off the gas it just shuts right off.. i have to hold it open at 2-3K to get it to stay running.

thoughts? i am really hoping to get things going well before my next racing round (2 weeks)

Could it be a timing chain alignment issue? cabling? i have no idea.

-jason
mdabyo is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 08-30-2011, 08:21 AM
I eat my R6
 
cheefar6's Avatar
 
Join Date: May 2010
Location: SoCal
Posts: 2,028
Bike: 2008 YZF-R6 x2
Re: 2007 R6 wont idle after rebuild

It could be a lot of things, but I would start with basics. Since it runs fine under liad, make sure the throttle position sensor is properly calibrated, and also check the throttle assembly. Make sure the line has right amnt of slack.
after that I would take a look at the ecu mapping, make sure that's not cutting fuel.



Posted using Tapatalk on Android.
cheefar6 is offline  
post #3 of 7 (permalink) Old 08-30-2011, 12:32 PM Thread Starter
R6 for Life
 
Join Date: Apr 2011
Posts: 18
Bike: 03,06 and 07 R6's
Re: 2007 R6 wont idle after rebuild

Ya, i swapped out Throttle bodies yesterday so that should take care of the TPS, but i will check the assembly and hoses..

The ecu map should be good.. I had it in another bike and all ran well there.

-J
mdabyo is offline  
 
post #4 of 7 (permalink) Old 08-30-2011, 03:00 PM
I eat my R6
 
cheefar6's Avatar
 
Join Date: May 2010
Location: SoCal
Posts: 2,028
Bike: 2008 YZF-R6 x2
Re: 2007 R6 wont idle after rebuild

so your starting it like a carbed bike with a little throttle?

after its started and you back off to let it idle, whats it do, just turn off, or sputter to death?
cheefar6 is offline  
post #5 of 7 (permalink) Old 08-30-2011, 03:55 PM Thread Starter
R6 for Life
 
Join Date: Apr 2011
Posts: 18
Bike: 03,06 and 07 R6's
Re: 2007 R6 wont idle after rebuild

just turns off when i back off the throttle, if i hold it at 500-1K it runs fine, just does not rev it self to idle..
mdabyo is offline  
post #6 of 7 (permalink) Old 08-30-2011, 04:26 PM
It'll make Ya' blind!
 
RELAX-IMA-DOCTOR's Avatar
 
Join Date: Jun 2011
Location: Berea, Kentucky
Posts: 753
Bike: 98 YZ125--00 YZ250--05 R6
Re: 2007 R6 wont idle after rebuild

First have you tried adjusting your idle, if so what happend? Whats your compression, If the head gasket was shot, I would strut towards the top end.

Maybe spark plugs, coils, battery, power commander / fuel controller. ( if you have one )
Did you sync the throttle bodys?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Hill billyin it up!

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
RELAX-IMA-DOCTOR is offline  
post #7 of 7 (permalink) Old 09-01-2011, 07:35 AM Thread Starter
R6 for Life
 
Join Date: Apr 2011
Posts: 18
Bike: 03,06 and 07 R6's
Re: 2007 R6 wont idle after rebuild

Logged in and played with the computer last night, no help there.

So as of this morning this is what is happening:

Turn bike on, Hit the starter, the bike starts up right away.. runs on its own with no throttle or anything for about 10-15 second, then sputters and shuts off..

if i give it throttle then it will keep running, but as soon as i let go, off it goes..
mdabyo is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha R6 Forum: YZF-R6 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2009 r6 wont idle Exup-R6 General Discussions 6 01-01-2011 05:43 PM
02 r6 wont idle without choke solo92s10 Garage / Mechanical Help 4 09-01-2010 04:12 PM
2005 r6 rebuild-wont start kyle-r6 Garage / Mechanical Help 0 10-21-2009 02:43 PM
bike wont idle right black r/t Exhaust and fuel delivery 0 12-14-2007 11:12 AM
Bike wont start since rebuild... bavarianguy77 Garage / Mechanical Help 8 11-17-2005 12:42 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome