Yamaha R6 Forum: YZF-R6 Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hey guys, before anything I have done so much research on this that I'm just going crazy. The bike sat for a while and now I did decided to bring it back to life. At first I wasn't getting power at the starter switch, bc the neutral switch is bad so I ground it and now neutral light comes on and I'm I can finally hear the bike turn when I hit the switch, lets get to the main problem now.

My bike is turning, I bought a brand new battery (today), bypassed the neutral switch, kickstand switch and my bike has no spark at the sparkplugs (took it out to test), which are brand new by the way. Kill switch works bc when I slap it down I can hear the fuel pump prime. I can hear the bike turning when pressing the starter switch, but it doesn't fire up, no spark. Everything else works on the bike, keep in mind I'm doing this with my tank off the bike, so idk if that has anything to do with spark at the plugs which I doubt. I'm really trying to enjoy my bike bc I love it but I can't seem to figure out the problem. I even tried to see if I have a tip-over switch and 99-02s didn't carry one. Cheers to everyone.:BS
 

·
Big ol pile of them bones
Joined
·
1,620 Posts
What did you do to bypass the side stand switch?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
I unplugged the blue connector under seat that lead to the switch and ran a wire from side to side on same clip. I'm starting to think its the "pick up coil" switch or the cdi. The 98-02 r6s didn't have a crank sensor I believe. If it's the pick up coil switch, where can I buy one, I can't seem to find one online.
 

·
Big ol pile of them bones
Joined
·
1,620 Posts
Pick up coil is in the right side cover (brake side).



 
1 - 5 of 5 Posts
Top