Yamaha R6 Forum: YZF-R6 Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 · (Edited)
-13k Miles
-New spark plugs (NGK)
-new coils (coilspec)
-has an ever so slight idle away from 1,750.
-stock air filter
-all TPS sensors within spec.
-stock headers

I know 2nd gen has a common coil issue so I replaced them and the plugs but it didn’t solve the problem. It will hold idle with slight deviation 75% of the time but will eventually not idle at all and stall. Here’s the weird part, I turn the key off and back on and it resets and idles again. I’m thinking it’s a faulty ECU but I also have a carbon fiber yoshi slip on. Just wondering if anybody knows if just a slip on could cause performance issue like this and I just need a commander on it or not, or if it could be anything else. I feel as if it was a faulty ECU there would be a much more noticeable problem so I’m Not quite sure. Switch from a stock air filter? My only logical guess would be there’s an air flow problem. I clean my filters and spray the appropriate amount of treatment on it.
 

·
Registered
Joined
·
12 Posts
@MATT2P Trying to get some longer term feedback on Coilspec coils. I have a 03 R6 and replaced my coils with Coilspec back in 2017. It's been no more than 2-3K miles and now the bike is dragging as if a coil or 2 are bad. I took them out and the resistance are in spec but I see in posts that you can't completely use resistance to determine if they are good or bad. So, I am wondering just how durable Coilspec coils are. How have yours been?
 

·
Registered
Joined
·
12 Posts
Quick follow-up. I retested my coils for resistance and one was bad with secondary resistance. I don't know how I missed that the first time but clearly user error. As to Coilspec, customer service was great helping getting a replacement. Long term durability is still yet to be seen but Coilspec customer service would have me go back to them. Thanks.
 
1 - 4 of 4 Posts
Top