Yamaha R6 Forum: YZF-R6 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi guys, first post here. I got a 05 r6 used and the cluster doesnt work, only the lights on the right (neutral, right indicator, brights etc) work. I had it tested and apparently its fried. I need to find a used one from a salvage yard but i want to know if i could use a newer on such a from a 2007 or so. Which ones would work?
 

·
Registered
Joined
·
1,940 Posts
No. The pin-out on the connector is different. The headlight sub harness is also different. I think you're stuck with 2003-05 clusters if you want a straight forward swap.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Thanks guys, i had a look now and yeah the 06-09 r6s has the same looking cluster, bike even looks the same. Im in south africa and im not sure we even get the r6s though. But either way, will look for a cluster that looks the same as mine. Found out you can actually use the newer style cluster like on the 2006 and up r6, but requires changing the wires in the pins, but then for some reason the speed reading will be off by around 15% without a speedo healer or whatever its called.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
So i managed to get clocks for a bargain and they work perfectly, but now the odometer obviously has the reading from the bike it came off of. I have no idea what the actual mileage is on my bike, is there any way to find out? Is all the info stored on the clocks or does the ecu keep that data too? The bike is with no papers so i dont have the history of it..
 
1 - 6 of 6 Posts
Top