Yamaha R6 Forum: YZF-R6 Forums banner

1 - 8 of 8 Posts

·
Love me some Yamaha
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey guys I'm brand new to the forum and need a little help. I just purchased my 2005 r6 about a week ago bare bones stock with 9000 miles on it. When I got it I rode it a little for a few days and it drove just fine. I then changed the oil, flushed the coolant and replaced it, and put a slip on exhaust on. Just in the past couple of days it has been doing some weird stuff. When I first turn it on (whether it be first ride in the morning, or after driving to school and turning it on again after a few hours of class) it idles extremely low like it is about to turn off. Today it even idled real low and shut off on me after just a 2-3 seconds. If I gas it while turning it on the idle goes up to 1500 rpm fine. ALSO, the idle is jumping around from about 1700- 1500 back and forth like a rhythm when just idling. Isn't it supposed to be a nice constant sound?? Another thing is I clocked the mpg from a full fill up and got just about 80 miles to the full tank (around 3.2 gallons) seems a little low?? Another thing is that in 1st gear from a stop it seems sluggish with constant building throttle and then comes to life a little more at about 5000 rpm, is that normal? I have been trying to figure out the problem, and don't know whether to start with changing the spark plugs, cleaning the TPS sensor, or what! Please help! I appreciate any info!
 

·
My R6 goes BWAHH
Joined
·
3 Posts
This may seem crazy but I'm having the exact same issue with my 2003 r6, I'm thinking it could be bad fuel? But no idea. All the help would be awesome!
 

·
Banned
Joined
·
7,347 Posts
A aftermarket exhaust makes the idle bounce and stay low. There's a gold colored knob above the clutch cover (big cover on right side of engine). You can raise the idle with it. I keep mine at 1500 when hot. Seems the best for me.

If that doesnt help try getting a power commander and get a dyno tune.
 

·
My R6 goes BWAHH
Joined
·
3 Posts
A aftermarket exhaust makes the idle bounce and stay low. There's a gold colored knob above the clutch cover (big cover on right side of engine). You can raise the idle with it. I keep mine at 1500 when hot. Seems the best for me.

If that doesnt help try getting a power commander and get a dyno tune.
I have a power commander on mine and I think that's the issue. Also have a full system arata exhaust with vortex velocity stacks and the idle is the same. In my eyes, the power commander is like adding another computer, so might try removing that and see what happens. Will definitely try the idle tune tho.
I'll post back here see if works out.
 

·
Registered
Joined
·
33 Posts
Had the same problem on mine. Twice actually. Coils and plugs the first time cleared it up. Installed an Akrapovic full system w/o a power commander and it started acting after ~2500 miles of riding. PC3 and the Akra map, silky smooth.
 

·
Registered
Joined
·
33 Posts
This may seem crazy but I'm having the exact same issue with my 2003 r6, I'm thinking it could be bad fuel? But no idea. All the help would be awesome!
Not sure if you've done this already but there is a recall on the 2003 for the ignition coils. That may also be causing yours to act up.
 
1 - 8 of 8 Posts
Top