Yamaha R6 Forum: YZF-R6 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
i have a 2012 yamaha r6 it was just starting and running fine. then it suddenly died sounded like a 2 cylinder and now wont statt. coils are good plugs are good fuel pump is working, i even tried to put my friends tank on my bike,ecu , rectifier,tio angle sensor and relay still the same outcome now im lost j cant find the lroblem why my bike is not statting can anyone help me.. and alsy my injectors are running fine no codes on the bike. the only thing i installed is my pilot light where i just insertid the wore on the headlight and after that those symptoms came in and died.
 

·
Zip ties and Duct tape
Joined
·
172 Posts
Make sure the kickstand killswitch is actuating as should. is the bike even cranking when you try and start it?
 

·
Registered
Joined
·
1,622 Posts
The title says it's not cranking.
The post implies that it isn't starting.

I'm going to ignore the title and assume you mean that it's cranking, but not starting.

Any changes from stock? Bought used? Was there a rat's nest of wiring?

I'm wondering if the charging system went, took out your starting circuit cut-off relay. There's no mention of the word "fuse" on this page.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
the first problem was the rectifier. i changed it out and it started now all of a sudden it wont start now. my coils are all good and working the Fuel injectors are also working but still the bike wont. the kick stand switch is i by passed the wire and tied tem together



and i bought the bike used with 6k miles on it. took of the tank and all the wires still look factory and no rat nest. it starts if i tried spraying brake cleaner on the throttle body. and all of a sudden after starting it. it sounded like a 2 cylinder and died. and after that it wont start anymore
 

·
Registered
Joined
·
1,622 Posts
From what I think I recall, the third-Gen lacks a diagnostic mode like the second generation. I don't recall what year 3rd-Gen starts. But if you have a diagnostic mode then you'll be able to use it to individually test each cylinder-spark, each fuel injector, fuel pump.

Wonder whether the fuel pump is a PWM operated motor or is it a simple fuel return system? If it's the latter, can simply test for 12v at the fuel pump, and even power it directly while disconnected from its normal source. If it's some sort of variable speed control then that easy option is out.
 

·
Fat + S = Fast
Joined
·
1,150 Posts
II had a similar problem once that turned out to be massive vacuum leak around the throttle bodies. Check that everything is well seat in its boots.
 
1 - 6 of 6 Posts
Top