Yamaha R6 Forum: YZF-R6 Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
So I've been reading around about the servo motor being unplugged/plugged in and the exup eliminator being plugged in to eliminate the CEL.

I've been told that if you still have your servo motor plugged in with the two cables dangling but have a slip on your CEL will not show up.

Another thread I seen if you have it still in but the two cables dangling your CEL will show up.

Can someone clear this up for me?
I have a 2006 R6, it has a shorty slip on with a k&n filter and the servo motor is still plugged in and the CEL IS on. It comes and goes when I'm riding fast on the highway.
 

·
nova r6
Joined
·
3,228 Posts
Go into the diag mode and see what codes are being stored, It might not even be anything related to the servo

http://www.r6messagenet.com/forums/pdf/2006R6Service.pdf

Start at page 8-40 or page 351 depending on pdf reader, go to d61 on your dash, it will rattle off some numbers write these numbers down. 352-354 give you the meaning of these numbers and you can proceed from there.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #3 ·
Go into the diag mode and see what codes are being stored, It might not even be anything related to the servo

http://www.r6messagenet.com/forums/pdf/2006R6Service.pdf

Start at page 8-40 or page 351 depending on pdf reader, go to d61 on your dash, it will rattle off some numbers write these numbers down. 352-354 give you the meaning of these numbers and you can proceed from there.
It's code 18, for CEL, i'm going to look at the manual when I get to work but it's only code 18.
 

·
Premium Member
Joined
·
1,095 Posts
You can leave the servo plugged in and just disconnect the cables. This is what I did, and no code pops. For all the ecu knows, the servo is still doing its job.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #6 ·
That is the code for the EXUP,

EXUP servo motor is stuck.

• Open or short circuit in wire harness.
• Stuck EXUP servo motor (mechanism).
• Stuck EXUP servo motor (motor).
What are ways of fixing this? Here is another dilema; I rode it for about 20 minutes backroads and the CEL was gone the entire time. I parked, went to class and came back on my bike about 30 minutes later, rode again for about 15 minutes with NO CEL and then suddenly it came back on. Does that sound similar to anything?

You can leave the servo plugged in and just disconnect the cables. This is what I did, and no code pops. For all the ecu knows, the servo is still doing its job.
So there must be something wrong with the actual servo motor if mine comes on?
 

·
nova r6
Joined
·
3,228 Posts
Sounds like the servo motor itself is freezing up/ getting stuck. Dynojet does sell a servo eliminator for 65.00 retail

https://cart.dynojet.com/p-1756-exhaust-servo-removal-module-esrm.aspx

Im sure with some searching you could find it a little cheaper, or with some more searching maybe someone has come up with a DIY bypass (I dont know cause ive never had to look into this for my 05)
 

·
Mr. HER6
Joined
·
2,084 Posts
Sounds like the servo motor itself is freezing up/ getting stuck. Dynojet does sell a servo eliminator for 65.00 retail

https://cart.dynojet.com/p-1756-exhaust-servo-removal-module-esrm.aspx

Im sure with some searching you could find it a little cheaper, or with some more searching maybe someone has come up with a DIY bypass (I dont know cause ive never had to look into this for my 05)
Better than that is to just have it turned off in a reflash and kill 2 birds with one stone.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #10 ·
Better than that is to just have it turned off in a reflash and kill 2 birds with one stone.
Sounds like the servo motor itself is freezing up/ getting stuck. Dynojet does sell a servo eliminator for 65.00 retail

https://cart.dynojet.com/p-1756-exhaust-servo-removal-module-esrm.aspx

Im sure with some searching you could find it a little cheaper, or with some more searching maybe someone has come up with a DIY bypass (I dont know cause ive never had to look into this for my 05)
Yeah i'm getting it flashed during the winter I was just looking for the answer cuz idk which statement is true in my first post.. also the fact it comes on and off got me like :confused::confused:
 
1 - 10 of 10 Posts
Top