Yamaha R6 Forum: YZF-R6 Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
Ok so my front brake pads had about 9k miles on em, so I decided to get em changed. Also installed stainless steel brake lines. The new feel of my breaks are pretty friggin awesome - I love it. Shoulda done the mod earlier!

Only thing is, I still get the squeak during slight braking. Under hard braking there is no squeak. This problem had been slowly developing prior to switch the pads out. So now my question is - did I wait too long? Are my rotors messed up resulting in squeaking? Or is this to be expected with aftermarket brake pads?

Products installed are the Galfer Sintered HH Brake Pads and SS Brake Lines.

Let me know what you guys think...
 

·
My R6 has returned!!
Joined
·
1,930 Posts
^^^^^ scuff scuff scuff those pads. Though, I usually just do it on the sidewalk outside of the garage and brush it off afterwards. :)
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #4 ·
did you scuff the rotors with a scuffing pad?http://www.detailandstripes.com/scuffpads.html

did you bed in the pads?

btw, get your Micron exhausts asap. they went out of business.
Micron went out??? Ahhhh!! I guess I'll have to get that system earlier than planned! Do you know why they did?

Also yah I had Yamaha do the brake pads - so I'm guessing they didn't scrub em down. I'm thinking since there's no real damage in having squeaky breaks, I'll just wait for the new rotors. Right now I'm lookin at some Brembo ones that seem quite nice...
 
1 - 4 of 4 Posts
Top