Yamaha R6 Forum: YZF-R6 Forums banner
1 - 20 of 23 Posts

·
Sammiches
Joined
·
1,435 Posts
Discussion Starter · #1 ·
Has anyone else had a check engine come on with code 18? I took it to the dealer a couple times already, and they loosened the exhaust valve cables but the light keeps coming on and going out all by itself. Havent experienced any problems as a result though. Any ideas?
 

·
Fancy crotch smell
Joined
·
368 Posts
just disconnect your exup cables. They are probably stuck, ergo the motor can't move, causing your bike to throw an CEL. If you remove the cables, the motor can do its thing and your bike will be happy again. ;-)
 

·
Sammiches
Joined
·
1,435 Posts
Discussion Starter · #4 ·
just disconnect your exup cables. They are probably stuck, ergo the motor can't move, causing your bike to throw an CEL. If you remove the cables, the motor can do its thing and your bike will be happy again. ;-)
I guess I'll just do that, good practice for when I get an exhaust since I'll have to anyway, I take it the light wont stay on permanently once the cables are removed? I have yet to play with it myself.
 

·
Fancy crotch smell
Joined
·
368 Posts
You might have to reset the bikes CPU by disconnecting the battery for a few mins
 

·
Sammiches
Joined
·
1,435 Posts
Discussion Starter · #6 ·
You might have to reset the bikes CPU by disconnecting the battery for a few mins
i actually just disconnected the cables from the exup valve today and the light went away, they are still attatched to the motor and they are just hanging, but all seems well.
 

·
import crusher
Joined
·
0 Posts
I guess I'll just do that, good practice for when I get an exhaust since I'll have to anyway, I take it the light wont stay on permanently once the cables are removed? I have yet to play with it myself.
just called up my local bike performance place... said they have never heard of doing this... just dont want to blow the bike up... I currently have a code 17 on my 07 R6. Servo code, also how can the exup stay open or shut if you disconnect the cables????
 

·
Premium Member
Joined
·
1,627 Posts
the exup valve has a spring that "tries" to keep it open. If you take off the cables the valve stays completely open. I have the exup cables disconnected on my bike. A second option is to take apart the exup valve and lube it, and a third is to get a slip-on or a full exhaust. Every now and then the exup valve needs to be lubed.
 

·
CODE 4 Racing
Joined
·
66 Posts
just called up my local bike performance place... said they have never heard of doing this... just dont want to blow the bike up... I currently have a code 17 on my 07 R6. Servo code, also how can the exup stay open or shut if you disconnect the cables????
I have a constent code 17, this is because I completely removed the entire exup servo(did you disconnect yours?) when putting on my race system.
 

·
Registered
Joined
·
68 Posts
you don't have to disconnect the cables. the value is just stuck. it happened to me before. you just have to take the cap off the push the value open/close. its very simple. if you google the code, there should be several diy with pictures posted in other forums. don't worry about it, its easy :)
 

·
Cant get enough of my 6
Joined
·
973 Posts
but if you just disconnect the cables without removing the butterfly in the canister wont that not alow the exhaust to escape??? or is there a fail safe that will keep the butterfly open
 

·
Registered
Joined
·
119 Posts
yah this happens to me daily i hate it. i dont know how to disconnect the cables either and the bike loses ALOT of power when the check engine light comes on. Its unbelievable
 

·
Registered
Joined
·
108 Posts
yah this happens to me daily i hate it. i dont know how to disconnect the cables either and the bike loses ALOT of power when the check engine light comes on. Its unbelievable
Just pull the black muffler cover off (at the base of the exhaust/faring) to expose the exup valve location. There you will see the cables and exup valve, try to give it a little smack to see if that will break it loose so it opens and closes freely...
 

·
Registered
Joined
·
37 Posts
yah this happens to me daily i hate it. i dont know how to disconnect the cables either and the bike loses ALOT of power when the check engine light comes on. Its unbelievable
It was happening to me as well.. what I did was lube/grease the actual exup valve, and cable. After that I would run the exup valve diagnostic a few times, and it never came back.
 

·
IRONHEAD
Joined
·
39 Posts
I have a constent code 17, this is because I completely removed the entire exup servo(did you disconnect yours?) when putting on my race system.

i also removed mine, will the light eventually go away? should i leave my battery disconnected for awhile?
 

·
Registered
Joined
·
9 Posts
I just replaced a scratched up can with another OEM one (I know, but I got it dirt cheap). I had a helluva time re-attaching the exup cables to the valve control+spring at the base of the exhaust. After the install, the max play I get with the valve is all the way closed to about half closed. Is it better to just remove the cables and leave the valve entirely open? What are the effects of the valve in the first place, other than obviously dynamically changing the exhaust flux. Decrease in HP?
 

·
Registered
Joined
·
15 Posts
lol i think that is the same problem wit mine, comes on an off but doesnt change way bike runs. so never got it check.
 
1 - 20 of 23 Posts
Top