Yamaha R6 Forum: YZF-R6 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hey guys and gals,

I've had my r6 for 2 years now, everything was great when I got it apart from the dash indicator light wasn't working... At the moment ive only been riding approx 4 miles to and from work.... everything had been fine... 1 month ago I replaced my battery as old one wasn't holding charge anymore even after having charged it... so replaced battery, fitted new battery 3 weeks ago and bike was fine again... however it seems to be not holding its charge again....

Anybody got any ideas for me here please ?
 

·
Registered
Joined
·
8 Posts
Hey guys and gals,

I've had my r6 for 2 years now, everything was great when I got it apart from the dash indicator light wasn't working... At the moment ive only been riding approx 4 miles to and from work.... everything had been fine... 1 month ago I replaced my battery as old one wasn't holding charge anymore even after having charged it... so replaced battery, fitted new battery 3 weeks ago and bike was fine again... however it seems to be not holding its charge again....

Anybody got any ideas for me here please ?
bring her to autozone, pepboys, advance auto parts. let them access your battery.... they can check her with their computer if ur battery or starter or alternator is malfunction for free!!!!!!!
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
bring her to autozone, pepboys, advance auto parts. let them access your battery.... they can check her with their computer if ur battery or starter or alternator is malfunction for free!!!!!!!
This in the UK ?
 
1 - 3 of 3 Posts
Top