Yamaha R6 Forum: YZF-R6 Forums banner
1 - 7 of 7 Posts

·
Teach me the track!
Joined
·
72 Posts
Discussion Starter · #1 ·
Hey guys, I've saw alot of threads on here about this topic. Most of those threads are due to people not remapping. I recently added graves block offs, BMC filter, and MJS headers with a Leo slip on. I let my bike heat up(205 at the time) and gave it a few revs and it popped some flames. My ECU has been flashed and mapped for everything. Im wondering if it's happening due to the bike being so hot, or if it could be something else?
 

·
Teach me the track!
Joined
·
72 Posts
Discussion Starter · #3 ·
Depends what you consider normal lol... Sounds like its running rich to me, but i want to fix it to get the most out of my bike
 

·
Registered
Joined
·
284 Posts
I used to have an air-fuel ratio gauge on my bike before it got soaked in the rain lol. My ratios were 12.5 at WOT and 13.6 or so cruising around and sometimes it would backfire. I would say enjoy the music from the exhaust lol. But if you want to be sure you can take the bike to a shop that has a dyno and you can find out how your bike is running.
 

·
Parts Pimp
Joined
·
26,470 Posts
The flames are from when the bike has fuel added in the map, then when you chop the throttle it goes lean. The lean condition off throttle makes hotter exhaust temps and that's when it ignites. If you rev the bike with a live afr readout that's what you'll see. When revving in neutral it's unavoidable when you're gassing and chopping the gas.

If it's decel popping like crazy then the map may be richened a bit. But even with 28%+ fuel at 0% throttle we still get some decel popping and a bitIf flamage here and there
 

·
Teach me the track!
Joined
·
72 Posts
Discussion Starter · #6 ·
Thanks for the replies everyone! Thanks Ant, that was a really good explanation. I appreciate it.:D
 
1 - 7 of 7 Posts
Top