Yamaha R6 Forum: YZF-R6 Forums banner
1 - 12 of 12 Posts

·
My R6 eats you.
Joined
·
7,563 Posts
Discussion Starter · #1 · (Edited)
2007 R6 with 19k miles. Bike idles fine until it is revved, it will idle below spec or stall for a moment then return to normal idle. Warmed up and ridden for a while it will do this intermittently, coming to a stop it will idle low, almost to the point of stalling then return to normal idle. What should I check? Sound like TPS issues? Problem started recently, runs fine when riding.
 

·
Premium Member
Joined
·
20,432 Posts
Full system?? Programmer?? My 07 after Full Leo and Power Commander is a rough idle and is really finicky tell it warms up to about 140. If I rev it at all before it hits 140~ it will die..
 

·
Premium Member
Joined
·
20,432 Posts
:( Got me then.. I would guess something to do with the TPS but will wait for a more experienced wrench turner than myself to chime in.
 

·
Ya wheelies is garbage!
Joined
·
5,935 Posts
From what I've deduced, valves out of spec, clogged injectors, or cam chain tensioner.
Yea, sounds like valve clearance to me. I remember that being an issue and more than a couple people online bitching about needing the adjustment well before it's scheduled interval. Not sure about the 3rd gens but I would assume that a worn CCT would be similar to what is noticed on a 1st or 2nd gen, they make a whirling noise that is impossible to ignore. That and that yamaha tick can get more noticeable because of the slight variation in timing and when the valves are opening and closing in relation to one another. So if you aren't experiencing those noises I would lean more towards the clogged injector or the valves. In all honest not really sure how to check the injectors. And not sure what to tell you about using seafoam or some other injector cleaner. Some people swear by it and some people said it made the problems worse and clogged the injectors more by loosening deposits in the tank or elsewhere. You seem like a pretty mechanically savvy guy since you have done most of your work or at least installs other than you fork seals yourself. I think you are capable of checking your valve clearance to see if they are in spec or not.
 

·
Registered
Joined
·
158 Posts
i had the same issue but one morning the bike just didnt start, after trying to start it a few times now when i try to start it it makes a whirling sound like if it doesnt have compression or something, i mean its weird.
 
1 - 12 of 12 Posts
Top