Yamaha R6 Forum: YZF-R6 Forums banner

1 - 13 of 13 Posts

·
RallyR6
Joined
·
7 Posts
Discussion Starter #1
My turn signals on front and rear are not working.
my horn,my headlights,and my brakes are working fine,
i check the fuses on them and everything is good even the
turn signal fuse is good.
I was wondering if this is gonna be a relay?
and i just got the bike last week the guy told me that i have to
change the fuse box itself? does it supposed to make a clickin ]
sound everytime u trigger the turn signal switch? mine dont
click at all?...-2001 Yamaha r6
 

·
RallyR6
Joined
·
7 Posts
Discussion Starter #3
No I havent check the wirings yet, im bout to check them this weekend.
and ill prolly get another relay and see if it works.
Thx man.
 

·
Registered
Joined
·
3 Posts
sorry i am very new to this couldnt find the right thread but this one is very close, if someone could tell me how to post my own thread thatd be awesome or help me here? just got my first bike 05 r6 got a new back tire put on 3 days ago when i picked my bike up my headlights stopped working on high and low beam my blue dash light for high beam doesnt even come on everything else works all blinkers and tail lights. remember im very new to this and i dont wanna spend the $250 they want to dignose it. please help i cant ride till i get it fixed! :(
 

·
RallyR6
Joined
·
7 Posts
Discussion Starter #5
what I will do is check the fuse 1st then check the relay.

on my 2001 r6 im having problems with my turn signals, but im assuming its the wirings of the flush mount signals.

and do you have HID on your bike or stock?
if you have HID check the ballast see if its good or not.
if its good you can hear a click sound when you turn it on.
 

·
Registered
Joined
·
1,940 Posts
Classic case of low blinker fluid dude. Problem solved.
 

·
Stunt Rider
Joined
·
7,977 Posts
Yeah! I hate when my blinker fluid is low. Totally messes up my day.
 

·
RallyR6
Joined
·
7 Posts
Discussion Starter #10
LOL!!!! just going with my stupid flow!! low blinker fluid! lol! classic but still i just want these two guys to think that I didnt know. lol... relay is the problem!! :(
 

·
Registered
Joined
·
3 Posts
theres a few different relays which one is it if my headlights go out i changed all the fusses and my high beam light doesnt come on, on my dash?
 

·
2004 r6
Joined
·
1 Posts
i have a 04 r6 and am having the same problem,my led turn signals are not coming on and the arrow does not show on the instrument panel and it doesn't make a clicking noise and everything else works including the headlights,brake lights and horn.help!!!!!!!!!!!!
 
1 - 13 of 13 Posts
Top