Yamaha R6 Forum: YZF-R6 Forums banner

1 - 20 of 20 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Guys Help Me out - I am a new rider bought a 2003 R6 in February. I only go 50 miles after fill up before the light turns on!!! What is going on. I ride around at like 4 k RPM in the city nothing crazy and no heavy HIghway riding yet. An occasional scream to like 11K RPms thats about it. Oil was changed before putting away last season, only mods i have ar D&D slip on and wouldnt that help mpgs?
I appreciate any feedback, it doesnt seem right to me at all. 5200 miles on the bike. What do you guys average before the light goes on and what is left after the light goes on?
 

·
Registered
Joined
·
2,472 Posts
You should be getting between 120-150 miles before the light comes on. How much gas do you put in the tank at fillups? If you only put a gallon or so in there, then your gauge is bad, but if you have to put 3.5 gallons in every 50 miles, something is wrong.


P.S. Once the reserve light comes on, you SHOULD be able to put in around 3.5 gallons. If its less than that you're filling the bike up wrong. Make sure to hold the rubber nozzle up and just put the tip in (so to speak) while filling it up.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #4
Thanks for the response. About 2.7 gallons have been filling the tank up once the light goes on, but still the .8 gallon difference will not give me the 120 miles that you get before your light going on. I will fill up again tomorrow and let you know if more fit and how i do on Mpgs. Thanks again!
 

·
Registered
Joined
·
16 Posts
Discussion Starter #5
You were right... i filled up yesterday and 3.5 fit in the tank. Lets see how far that takes me.
 

·
Registered
Joined
·
65 Posts
i'm guessing you stuck the gas nozzle into the tank, and it basically cut off ~2 gallons....which means you only ran it for ~1 gallon until the light comes on again.


let us know how much u get after filling the gas tank to top
 

·
Garage Queen R6
Joined
·
719 Posts
have you checked to see if your bike falls under the recall for its ignition coils? Also, check your tire pressure and chain slack. They are often overlooked.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #9
Hey all Thanks for the replies.

I filled it up the other day, 3.5 gallons fit. My light came on today at 100 miles exactly.....still seems kind of low.That comes out to 28 mpg, cars can get that. My tire pressure is ok and the chain slack too... forgot to mention i have the 520 chain conversion stock gearing though.... dont know about the recall for ignition coils where do i check for that?
Air filter maybe?

Is cruising around at 4k rpm high, to mee that is low, people i know cruise around 7??

Thanks guys.
 

·
Registered
Joined
·
64 Posts
after reading this thread, on my 04 r6 i get about 110-120 and my light comes on. its stock bike.
but i dont fill it up all the way but close enuf.
i guess only thing i can see is that idle sensor to reduce rpm at idle.
mine is at .5k//

how about u guys? :confused:
 

·
Registered
Joined
·
337 Posts
Got an '06, sprocket -1/+2 and i get 120 mile exactly when the light comes on, and yes you should get like 3.5 gallons to fill it up to the lip of the metal thing inside tank. So i get 35 mpg and cruise highway at 7-8000 rpm
 

·
Go Tigers!
Joined
·
2,625 Posts
I squeezed out 180 miles on a tank the other day. 30 miles on reserve. With normal driving, i get 140-150 b4 light comes on. Bout 120 if im riding hard. 01, jet kit, k&n filter, yoshi pipe. My GF has a 04, slip on exhaust and gets about 150 till light comes on.
 

·
Registered
Joined
·
1,431 Posts
If you cruise around in 2nd all the time, you might be getting crappy milage. Cruise at higher gears, and you'll get better mpg's.
 

·
2B R <> 2B
Joined
·
3,703 Posts
Whats up...

99 - 01 Tank size 4.5 gallon

New model have 5 gallon tank I believe

Also your gas mileage changes according to how you ride...
 

·
I'm an adrenaline junkie!
Joined
·
34 Posts
Whats up...

99 - 01 Tank size 4.5 gallon

New model have 5 gallon tank I believe

Also your gas mileage changes according to how you ride...

I have an 08 and the tank is 4.7 gallons, I have -1/+2 and I left it at 525,
and I get about 120 before my light turns on and I go about another 25 miles before I fill up.
 

·
Shiney up Rubber down
Joined
·
4,936 Posts
Man... It sounds like your bike is either regeared funky or you're running REALLY rich. You're idle could be high, but I dont think that it would cause THAT bad of gas mileage. My bike is regeared at 15 52 and I can still get 28-32 MPG depending on how hard I ride.
Do you have a PC III on that bike... You might need a remap, or something. Let us know if there are any mods to the bike, that would help out alot more in figuring out your problem
I would also suggest that you fill your bike up all the way. When you put the gas nozzle into your tank, have it so the tip of the nozzle is JUST BARELY inside the metal splash gaurd. You'll fit more gas in your tank that way. it's a 4.5 Gallon tank, you should be albe to fit almost 3.75 gallons in it when that light comes on.

Get back to us with that info and maybe we can help you figure more out.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #17
OK SOO.... I checked tire pressure, am running it pretty high 40psi, cleaned the chain and tightened it, cleaned the airfilter, filled up to the brim 93 octane and still only got 108 miles until the light came on... i shift at around 5k rpm ...a little bit of highway at 60-80mph for about 8 miles/day, rest is city driving. Still low right? what else can i check? Thanks all!
 

·
My R6 eats Chuck Norris
Joined
·
2,407 Posts
I squeezed out 180 miles on a tank the other day. 30 miles on reserve. With normal driving, i get 140-150 b4 light comes on. Bout 120 if im riding hard. 01, jet kit, k&n filter, yoshi pipe. My GF has a 04, slip on exhaust and gets about 150 till light comes on.
That settles it! My 02 has a jet kit and your the only one I've seen getting my kind of mileage... must be the carbs! I knew the old ones were better!:poke
 

·
Registered
Joined
·
61 Posts
My 06' R6 doesn't even reach 100 before the light comes on. i get around 95 miles when the light comes on. I pump exactly 3 gallons after that. Something is wrong with mine too. Everything is stock. I haven't been running it hard either. I haven't checked the oil or air filter yet. Could that be the problem?
 
1 - 20 of 20 Posts
Top