Yamaha R6 Forum: YZF-R6 Forums banner

1 - 20 of 31 Posts

·
Yamaland
Joined
·
2,309 Posts
Discussion Starter · #1 ·
Hey guys, I'm in my garage right now installing my CA Led tails on my 05 R6. And I've got the tails hooked up, but I'm havin trouble with the turn signals.

It says to connect each yellow wire to the positive wire for each turn signal. Should I just cut the wires and connect the yellows? If so, what do I do with the ground?

Also, should I just cut the wire for the liscense plate light and tape it off?

Thanks in advance for helpin a newb.
 

·
Registered
Joined
·
7,662 Posts
the ground from the stock light is now useless if you are removing the stock lights. Your ground from the wire harness is now the good ground.

Just hook up the positive (+) from the stock blinker to the yellow wire. All it is using is the "trigger" from it.

if you are not using a tag light, then yes, just unplug it and tape it off. I never actually "CUT" stock wire plugs off...you may just need them again someday...
 

·
Yamaland
Joined
·
2,309 Posts
Discussion Starter · #4 ·
Okay, so I got it hooked up. Both turnsignals work perfectly, but when I hit the brakes, only the right side LED's light up. Aren't both sides suppose to light up on the CA tails? Any idea why only one side would be lighting up when i hit the brakes. Its the right side btw.
 

·
Yamaland
Joined
·
2,309 Posts
Discussion Starter · #5 ·
when the bike is on, both sides light up, like running lights, then when i hit the brakes, only the right side gets brighter. Might this be a defective kit?
 

·
Yamaland
Joined
·
2,309 Posts
Discussion Starter · #7 ·
Yeah, I think its a defective kit. I just called CA, they are sending me out a new one today, and then I'll ship them back the defective one. I guess even though they sent me a defective kit, their customer service is good. Now I just gotta wait fot the new kit to come in.
 

·
Registered
Joined
·
7,662 Posts
damn...all that work and it doesn't work...
I have to agree, it sounds defective. The brake light should illuminate both sides. Is your ground good?
 

·
Registered
Joined
·
7,662 Posts
^^^^Disregard :)

Good to know they have good customer service!!
 

·
Yamaland
Joined
·
2,309 Posts
Discussion Starter · #11 ·
Yeah, I checked it before I put it back together, and thats when I found out it was defective. As soon as I wired up both turnsignals I checked and saw that the right side wasnt getting brighter.

So I called and spoke to some guy. He took my info right over the phone and said that a new one would be shipped tomorrow. And to just send back the defective one when the new one came in. They're takin care of shipping both ways.
 

·
Registered
Joined
·
311 Posts
Ok good, it woulda sucked if you put it all together and then realized it was defective, the undertail is annoying as hell to get them damn hole locations lined up!
 

·
Registered
Joined
·
51 Posts
Crap! Just found out mine is doing the same thing, the left side brake is not coming on. Called and left a message with them, waiting to call back.
 

·
Registered
Joined
·
51 Posts
Called CA again and got them on the phone. While I was on the phone, he was taking care of another customer with the same issue..... Seems like they have a pattern on this. At any rate, they will send out a replacement unit within the next couple days. Atleast the support for their product is good, no complaints here.
 

·
FL45HM3
Joined
·
955 Posts
Sucks to hear that both of you got defective kits, but atleast you have new ones on the way to your houses... and the kickass thing is that they are sending you the new unit BEFORE you have to send the defective one back. Thats kind of weird that they have had a few act up like this. Maybe they just had a bad batch or something.

When I got mine, everything worked fine and it exceeded my expectations. Trust me... when you get one where both brake lights light up... you won't be disappointed. :hammer
 

·
Registered
Joined
·
373 Posts
Glad to hear they have good customer service. I love my new taillight as well. I also created my own license plate light holder, so I'm completely legal at night. It doesn't look all that great right now, but I will be changing it in the future. I just wanted to make sure I got the light on it to begin with.
 

·
Yamaland
Joined
·
2,309 Posts
Discussion Starter · #17 ·
Yeah the customer service was great. Well, they sent me new taillights, but they sent the wrong ones, so I called them back, and they immediately sent out the right ones. I got them today, and I plan on installing them tomorrow.

So even though they sent me defective tails, then the wrong ones, then the right ones, I'm still pleased with their customer service.

And I would recommend them.
 

·
Yamaland
Joined
·
2,309 Posts
Discussion Starter · #18 ·
update:

I just installed the CA tails. They sent the right ones this time and they work great. I really like the look of them. it helps to clean up the back end real nicely.

Would recommend them
 
1 - 20 of 31 Posts
Top