Yamaha R6 Forum: YZF-R6 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi Im new here but freaking out a bit.

I ride everyday and the other day i turned my key and nothing came on. Including headlight, gas pump, any console lights and it woulnt start.

I think it is the ignition but I dont know how to be sure. I am not really mechanically inclined but hoping I can do it.

I have looked at the service guide but I am hoping someone can be a little more specific about what the issue is.

Oh yeah i dont even have an R6 i have 600r :( 2003 but i think they are very similar as far as starter and stuff go.
 

·
Registered
Joined
·
62 Posts
maybe the battery is dead try to jump start it or if you have a charger charge it for a bit...and if that dont work check the batt connections and make sure the terminals are clean with no corrosion an reconnect the batt cables
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
hey thanks for the reply, but I tested the bat with a volt meter and it is fine. Its also pretty new.
 

·
Registered
Joined
·
324 Posts
hmm did u try wiggleing? (sp?) the key see if u get anything to turn on. Sounds like something other than ignition to me. Check your main fuses i would check the battery too again with a battery tester just because the voltage is up doesnt mean the amperage is.
 

·
Registered
Joined
·
5 Posts
Well you say "the other day"does that mean you dot it started?If so what did you do to get it started and if you did..then there is prob a short some where..I would check all the wires for cracks or cuts or just being loose.
 
1 - 5 of 5 Posts
Top