Yamaha R6 Forum: YZF-R6 Forums banner
1 - 20 of 29 Posts

·
Disturbed1
Joined
·
57 Posts
Discussion Starter · #1 ·
Hi guys,

Just installed a Delkevic 200mm Carbon Stubby pipe on my 2000 r6 http://cbrforum.com/forum/showthread.php?t=106868, It already has an aftermarket exhaust on so it was a pretty easy task I just replaced the slip on and didnt bother messing with the link pipe as it was the exact same size as the one I got with the new pipe.
So the new pipe was on and I fired up my bike, it sounds amazing however when the bike is at idle the revs bounce off about 1k so its making a really annoying sound. I took it out for a spin and its absoloutley fine everywhere else through the rev counter but when I come to some traffic lights there it is.
I then did a little test and put my origional pipe back on and the revs were absoloutley fine just a nice constant rumble.

Im guessing its gonna need rejetting for this new pipe? Delkevic do say its not required but Im not keeping it on my bike if its doing that to my engine.......

Please help me out, I want it on!!!

Cheers, Luke
 

·
Registered
Joined
·
327 Posts
How much did it run you if you don't mind me askin?
 

·
Registered
Joined
·
327 Posts
Well thats not to bad at all. It looks so good!

Every vehicle I own at the moment has "illegal" exhaust :lmao
 

·
Registered
Joined
·
1,654 Posts
Hi guys,

Just installed a Delkevic 200mm Carbon Stubby pipe on my 2000 r6 http://cbrforum.com/forum/showthread.php?t=106868, It already has an aftermarket exhaust on so it was a pretty easy task I just replaced the slip on and didnt bother messing with the link pipe as it was the exact same size as the one I got with the new pipe.
So the new pipe was on and I fired up my bike, it sounds amazing however when the bike is at idle the revs bounce off about 1k so its making a really annoying sound. I took it out for a spin and its absoloutley fine everywhere else through the rev counter but when I come to some traffic lights there it is.
I then did a little test and put my origional pipe back on and the revs were absoloutley fine just a nice constant rumble.

Im guessing its gonna need rejetting for this new pipe? Delkevic do say its not required but Im not keeping it on my bike if its doing that to my engine.......

Please help me out, I want it on!!!

Cheers, Luke
very interested on putting it on my 1st gen after seeing ur post.....you have some some pics of the whole bike on the exhaust side? just wana see how a shorty looks like on a 1st gen r6..thnks
 

·
Registered
Joined
·
1,654 Posts
Hi guys,

Just installed a Delkevic 200mm Carbon Stubby pipe on my 2000 r6 http://cbrforum.com/forum/showthread.php?t=106868, It already has an aftermarket exhaust on so it was a pretty easy task I just replaced the slip on and didnt bother messing with the link pipe as it was the exact same size as the one I got with the new pipe.
So the new pipe was on and I fired up my bike, it sounds amazing however when the bike is at idle the revs bounce off about 1k so its making a really annoying sound. I took it out for a spin and its absoloutley fine everywhere else through the rev counter but when I come to some traffic lights there it is.
I then did a little test and put my origional pipe back on and the revs were absoloutley fine just a nice constant rumble.

Im guessing its gonna need rejetting for this new pipe? Delkevic do say its not required but Im not keeping it on my bike if its doing that to my engine.......

Please help me out, I want it on!!!

Cheers, Luke


maybe if you use the pipe that came with the box... i know u said it fits perfect but they must have included a pipe for some reason...not sure if this will fix it but it might..keep us posted..
 

·
Disturbed1
Joined
·
57 Posts
Discussion Starter · #16 ·
Ive only got the one picture sorry, I never made a video as Its not been permanantley on my bike yet. This morning I was playing about with it though and managed to 'reduce' the noises it was making, I used the link pipe that came with the Delkevic pipe and it would only splutter every now and then. So I might just take the risk and stick it on, then see about a dyno session to sort it out. I just think theres not enough fuel getting into it, so like I say ever now and then the revs would die for a second....
 

·
Disturbed1
Joined
·
57 Posts
Discussion Starter · #19 ·
Im getting it fitted to my bike next week so Ill update this with pics and a sound clip and maybe a fly by video if you all lucky lol.

Reason for professional fitment is that the link pipe is shorter than origional pipe so I need a new exhaust hanger making. Leaving it to the Pros as I generally f**k things up lol
 
1 - 20 of 29 Posts
Top