Yamaha R6 Forum: YZF-R6 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter #1
So i changed the plugs on my '03 for the first time today and noticed the coil packs looked dodgy. I was aware of the coil pack recall on 03 bikes through the r6 forums, but i was under the impression that it only affected US bikes. Last year to double check i even asked a local aussie dealer if there were any recalls, directly mentioning the coil problem i had read about in the US. there are no official recalls on 03 r6 here, and he said he hadn't heard of the problem.

Since then I assumed that we were lucky enough to have the mitsubishi coils from factory.

Wrong. I have the the junk Denso ones and they dont look healthy.

I havent got an exact quote from yamaha how much the coils are going to cost me, but know its going to be around $500 AUD ($450 USD) for all 4.

What are my options? Are there cheaper alternatives? My bike isnt showing any signs of power loss or stalling and as far as i know it runs as it should be with healthy coils... but they do look pretty burned through (must right be on the verge of arcing).

Please advise.
 

·
My R6.....
Joined
·
176 Posts
Hi mate,

I have the 03 and had no problems until she started running on two or three cylinders about 4 months ago. I thought it was the fuel injectors and even my mech didn't know what the go was. After a bit of research on this forum I suggested the coils problem to him and he was like, yeah that sounds like it could be the cause.
To date I have swapped out two of the ignition coils and she is working perfectly, but I know that sooner or later I will have to change the other two. My mech got them shipped over from Melbourne (I'm in Launceston) overnight and they were $115 each. I saved on the labor and installed them myself with no problems at all.
As I mentioned, I didn't change mine until I noticed the problem, but let me give you the hot tip - don't wait till it happens. I had a few scary moments going around corners with the bike almost cutting out.

I hope that helps.
 

·
Registered
Joined
·
2 Posts
I think I've got the same problem happening to my 03.
The idling is not constant and it tends to cut off at the lights when I pull the clutch in with the bike at a complete stop.
Have yet to pull the coils out and have a look.

AUD115 per coil is pretty steep. Aren't they half the price in the states?
 

·
My R6.....
Joined
·
176 Posts
I think I've got the same problem happening to my 03.
The idling is not constant and it tends to cut off at the lights when I pull the clutch in with the bike at a complete stop.
Have yet to pull the coils out and have a look.

AUD115 per coil is pretty steep. Aren't they half the price in the states?
Yeah, I was going to buy a set from ebay from a low km used bike, but got out bid and needed them pretty urgently so I just got my mechanic to order them for me. I am still keeping my eyes open for another two so that I can do them when i get around to it.
 
1 - 4 of 4 Posts
Top