Yamaha R6 Forum: YZF-R6 Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
320 Posts
Discussion Starter · #1 ·
got the clutch side on no problems. but the front brake side is kicking my ass. it seams i may have the wrong lever or something, the hole wont line up to put the pin through. is it a common mistake or do i have the wrong lever?
 

·
Registered
Joined
·
7,662 Posts
Sounds wrong...but not seeing it, I dunno. Mine went on easily on both sides, lined right up.
 

·
Registered
Joined
·
78 Posts
When i replaced some levers on my last dirtbike i had the same problem.

Thought i had the wrong lever but it turned out i had to take all the tension out of the cable, adjusted it down near the engine and on the bars, and it fit perfect. Then just tighten it back up. ;)
 

·
Premium Member
Joined
·
3,027 Posts
you shouldn't have to mess with the tension at all. i just took the old out out and replace it with the new pazzo no problems at all. but then again without any pictures it is hard to say.
 

·
Registered
Joined
·
320 Posts
Discussion Starter · #5 ·
can any one look under there lever theres like a part number. mine says "f-14" it wont line up to the hole where the bolt goes through to save my life. ill try to get a pic tomorow. this blows i have one pazzo and one stock :(
 

·
Registered
Joined
·
142 Posts
AS far as I know the stock bushing only comes from the clutch. Mind you I have an '03 so it could be totally different with your bike since it's an '08.

You proly have the wrong lever cuz even if you have to use the stock bushing it should still line up. If anything, even with using the stock bushing (if there is one for the '08 brake side) it would be harder to line up as you are making the hole smaller by adding the bushing.

Double check with who you bought it from.
 

·
Premium Member
Joined
·
18,783 Posts
Snow is right, you use the bushing out of the OEM. Remember to put a little grease on it. Then it will fit perfectly. And yes, it is a common mistake to not use the bushing based on older post.
 

·
Premium Member
Joined
·
11,269 Posts
AS far as I know the stock bushing only comes from the clutch. Mind you I have an '03 so it could be totally different with your bike since it's an '08.

You proly have the wrong lever cuz even if you have to use the stock bushing it should still line up. If anything, even with using the stock bushing (if there is one for the '08 brake side) it would be harder to line up as you are making the hole smaller by adding the bushing.

Double check with who you bought it from.
yeah sorry dude i totally just skimmed ur post and assumed that's what ur problem was. stoopid me :dunce: the only thing i could suggest on the brake side is that the pin on ur master cylinder might not be matched up with the dome shaped indentation on the side of the lever. otherwise, i'll check the model number for u when i'm by my bike. i have an '08 as well.

edit: and u have to change the specs in ur sig from "levers" to "lever" until you get the second one on. :*tongue j/k
 

·
Registered
Joined
·
320 Posts
Discussion Starter · #10 ·
well i think i have the wrong lever for the brake side then, because there is no way the bushing from the oem lever is going in the pazzo lever, the hole is smaller. if any one could check just to make sure it says t-14 under the lever. and ill try to get a pic today of how its not lining up. this blows. one more thing is it weird the clutch when went on perfect and brake isnt lining up?
 

·
Registered
Joined
·
320 Posts
Discussion Starter · #11 ·
well i just went and tryed again, theres no way in hell its going on there. so i looked it up on pazzo racing, i guess i need a r-104 lever and not a f14 lever, i bought them on ebay through a dealer so ill be calling them soon as they open to get this shit resovled. this blows.

can some one with an 08 check theres and see if r-104 is correct? the pazzo website says r-104 for the 07 model, but there isnt a updated part number for the 08 on there. im assuming they are the same. thanks in advance.
 

·
Registered
Joined
·
114 Posts
ouch, that sucks, where did you get them from? are they actually "pazzo"? mine from snowbizx went in like me in my gf, nice and tight.
 

·
Registered
Joined
·
20 Posts
i just got mine in the mail. i will try to install the tomorrow. Anybody knows where i can see a write uo on installing them. this is my first bike, so everything is new.
 

·
Ride It Like It's Stolen!
Joined
·
1,171 Posts
i just got mine in the mail. i will try to install the tomorrow. Anybody knows where i can see a write uo on installing them. this is my first bike, so everything is new.
Here's a "How to" thread on the 03-05's. I cant imagine them being all that different on your 08. Just got my pazzos too and will also be installing them tomorrow. Good Luck!

http://www.r6-forum.com/forums/showthread.php?t=22765
 

·
My R6 is my best friend.
Joined
·
101 Posts
part number on my 08 is r-108 or r-104, hard to read upside down in the dark...
Eaither way, they dont match up. I just pulled the cable back and put it in the hole then lined em up, if i can remember right. hope this helps...
Chris
 

·
nova r6
Joined
·
3,227 Posts
sounds like what happened to you happened to me also they sent me the wrong lever the 05 and newer have radial mounted calipers which have a different master cylinder than 03,04 and the r6s' pending on who you bought them from they should swap it for you no problem
 
1 - 19 of 19 Posts
Top