Yamaha R6 Forum: YZF-R6 Forums banner

1 - 20 of 33 Posts

·
Banned
Joined
·
337 Posts
Discussion Starter #1
11 - No normal signals are received from the cylinder identification sensor when the engine is started or while the vehicle is being driven.

12 - No normal signals are received from the cranshaft position sensor.

13 - Intake air pressure sensor: open or short circuit detected.

14 - Intake air pressure sensor: hose system malfunction (clogged or detached hose.)

15 - Throttle position sensor (for throttle valves): open or short circuit detected. Throttle position sensor (for throttle valves) coupler connection is loose.

17 - EXUP servo motor circuit: open or short circuit detected or loose connection.

18 - EXUP servo motor is stuck.

19 - Open circuit is detected in the input lead from the sidestand switch to the ECU.

20 - When the main switch is turned to "ON", the atmospheric pressure sensor voltage and intake air pressure sensor voltage differ greatly.

21 - Coolant temperature sensor: open or short circuit detected.

22 - Air temperature sensor: open or short circuit detected.

23 - Atmospheric pressure sensor: open or short circuit detected.

24 - No normal signal is received from the o2 sensor.

30 - Latch up detected. No normal signal is received from teh lean angle sensor.

33 - Open circuit detected in the primary lead of the cylinder #1 ignition coil.

34 - Open circuit detected in the primary lead of the cylinder #2 ignition coil.

35 - Open circuit detected in the primary lead of the cylinder #3 ignition coil.

36 - Open circuit detected in the primary lead of the cylinder #4 ignition coil.

39 - Open ciruit detected in a primary injector.

40 - Open circuit detected in a secondary injector.

41 - Lean angle sensor: open or short circuit detected.

42 - No normal signals are received from the speed sensor.
- Neutral switch: open or short circuit detected.

43 - Power supply to the injectors and the fuel pump is not normal.

44 - An error is detected while reading or writing on EE-PROM (CO adjustment value).

46 - Power supply is not normal.

50 - Faulty ECU memory. (When this malfunction is detected in teh ECU, the fault code number might not appear on the meter.)

59 - Throttle position sensor (for throttle cable pulley): open or short circuit detected. Throttle position sensor (for throttle cable pulley) coupler connection is loose.

60 - Throttle servo motor: open or short circuit detected. Defective throttle servo motor. Malfunction in ECU (servo motor driving system).

Er-1 - No signals are received from the ECU.

Er-2 - No signals are received from the ECU within the specified duration.

Er-3 - Data from teh ECU cannot be received correctly.

Er-4 - Non-registered data has been received from the meter.






there they all are. When something goes wrong with your bike and the fault number flashes across the lcd, you should find what you're looking for here. I know this is a large post, but I had to do it. For all those out there that need help, or would like to have a copy of the service manuals, you can find them here.

2007 Yamaha R6

http://www.r6messagenet.com/forums/pdf/2007_R6_Service.pdf




Peace
Love
and chicken grease.
:toocool:
 

·
Ain't nothin sweet
Joined
·
25 Posts
so what are 1-10? i know they are adjustments, but do you have any idea where i would find out what each individual one does(couldnt find anything in the service manual, but just gave it a skim so perhaps i missed it?)?
 

·
Burg
Joined
·
35 Posts
im getting er-1 :mad: but my bike starts up and every thing i just have no mph the fan kicks in when needed and all so the ecu is doing some work right?
 

·
ftp
Joined
·
86 Posts
to clear codes turn key off and hold both buttons on your guage cluster at same time. turn key on and hold for 8 sec it will take you to diagnostic mode hold another 2 sec and it will take you to another mode go up hit the top button on your ncluster till you get to 60 then hit the start button wahhh laaa codes cleared
 

·
Registered
Joined
·
3 Posts
is there a reason why i would get error code 1 after I hit the start button when i am trying to reset the codes?
 

·
Registered
Joined
·
1,016 Posts
anyone know what 70 is? I have 09 r6 and had it idling in the garage (i know i should not have, now I know better) and it just shut off by it self after about 15/20min. It said 70 on the LCD. I saw some stuff on google for f 70 with possible sensor overload to the engine management system. it started right back up no problem (I won't be letting it idle so long :/ :stupid) First time its ever happened. Thanks for the help.
 

·
Registered
Joined
·
1,016 Posts
some more research indicated there is an auto shutdown when bike idles for 20 minutes..code clears upon restarting...incase anyone else gets this same code..I won't be letting that happen again....
 

·
Ride Free
Joined
·
22 Posts
so trying to install a security system i think i hit the wrong wires. when i try to start the bike it desplays Er-2 which is ECU internal malfunction (output signal error) No signals are received from the ECU within the specified duration. can anyone explain what the hell that means?
 
1 - 20 of 33 Posts
Top