Yamaha R6 Forum: YZF-R6 Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
i got a 07 r6 and the turn signals work completely fine but the right signal flickers when i give it gas. i will tap the back under the seat area of the bike and the signal flickers so some loose wire or fuse is causing it but i dont know which or how to diagnose it. i bought this bike used so no owners manual here is a attached video of my bike and the issue


https://www.youtube.com/watch?v=49JpkOfud18
 

·
I said biiiiiiiitch.....
Joined
·
525 Posts
i got a 07 r6 and the turn signals work completely fine but the right signal flickers when i give it gas. i will tap the back under the seat area of the bike and the signal flickers so some loose wire or fuse is causing it but i dont know which or how to diagnose it. i bought this bike used so no owners manual here is a attached video of my bike and the issue


https://www.youtube.com/watch?v=49JpkOfud18
I'm guessing your actual turn signal flickers along with the indicator?

Your best bet is to grab a wiring diagram and start checking for loose connections. Depending on what signals you have on, check for loose bulbs too. I'm not sure if there is a technique that would make this any easier. I would probably just start reseating all the connections one by one until it goes away.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top