Yamaha R6 Forum: YZF-R6 Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
So bought this R6 a few days ago, rode fine until yesterday I felt it get pretty hot so I turned it off, let it cool a little bit, and then turned it back on. It has difficulty starting up but once it did, I gave it a few quick revs to bring the RPMs up because the idle seemed to be dropping, but the bike just ended up dying. I then tried to start it up again and now it just won’t start. It turns over and over but it won’t start. I’m thinking it’s probably a fuel/ignition related issue? I don’t think it’s the battery issue because it seems to be getting enough power. Any help would be appreciated. I will try and attach a video of what’s going on. Thanks
 

·
Registered
Joined
·
112 Posts
You would have to check the battery charge first, it could be a faulty spark plugs and coils.

The fuel pump is activated? When giving contact?

Regards.
 

·
Registered
Joined
·
2,294 Posts
Year?
MIleage?
Past maintenance, "modifications" from stock?
 

·
Registered
Joined
·
5 Posts
Check your starter relay I had a similar issue where my 07 would turn and turn but never kick over I was ready to rip out the fuel pump...turns out my starter relay was just a cheap knock off piece of shit and it wasn’t making good contact with the prong connection
 

·
Registered
Joined
·
7 Posts
Well i am getting spark and no fuel. I was able to get it to fire with some carb cleaner in the valves. I hear the fuel pump prime when I turn key on. Therefore between the fuel pump and injectors/fuel rail something is clogged......correct?
 

·
Registered
Joined
·
2,294 Posts
Put it in diag mode and watch your injectors fire with the airbox off. You'll want to confirm that it isn't spraying rather than make an assumption.
 

·
Registered
Joined
·
7 Posts
I guess my other question is , does the fuel push to the main rail or the fuel injectors when starting? There are two fuel rails correct? It 'Y's from the pump , one line to rail lower on engine block and one line to rail above for injectors.....so if I hook tank up fuel should come out of injector rail or both?
 

·
Registered
Joined
·
48 Posts
I'm not sure I'm understanding that question. The injectors are just valves. The fuel pump keeps fuel under pressure until the injectors open electrically. So the fuel pump sends pressure to the entire system whenever it runs.
 

·
YZFR6... ooodles of HP
Joined
·
886 Posts
2017 has 8 fuel injectors. 4 are in the top of the airbox. Those 4 only come on with high throttle open condition. The 4 injectors buried under the airbox ate responsible for normal fuel needs. Make sure kill switch is off (starter will turn engine). Turn key on. While tach does its full sweep you ahould hear the fuel pump prime. It is very loud and for about 2 seconds. If the kill switch is on the pump will not prime until the starter engages.
 

·
Registered
Joined
·
7 Posts
So if I hear the fuel pump prime, which I do, then the lower 4 injectors would be the reason for no fuel thus my spark plugs dry? Or is there something in between that I can check that would be easier??
 

·
YZFR6... ooodles of HP
Joined
·
886 Posts
Is reserve light on? Either no gas in tank, you ran out and lost prime, or electrical issue at injectors. If you prime the pump then shut it off and remove the fuel line clip does gas spray out?
 

·
Registered
Joined
·
5 Posts
So if I hear the fuel pump prime, which I do, then the lower 4 injectors would be the reason for no fuel thus my spark plugs dry? Or is there something in between that I can check that would be easier??
You can check your fuel pump relay under your tank behind your battery
 
1 - 15 of 15 Posts
Top