Yamaha R6 Forum: YZF-R6 Forums banner
1 - 4 of 4 Posts

·
Gambling every time u rid
Joined
·
81 Posts
Discussion Starter · #1 ·
So after 36k miles I"m getting a CEL and code 46. Yippi. I'm pretty sure it's just the rectifier. But, would you guys buy a brand new aftermarket one...or an OEM used one? Both have their pros and cons.... Seeing if anyone has had experience with either. Thanks!
 

·
"The Dude abides .. "
Joined
·
4,719 Posts
i have no issues buying used parts from reputable ebay sellers. look at the photos, ensure it's the right part for your bike, and check out the return policy the seller has. in most cases, they will have no problem exchanging a part that is defective to keep good feedback history (why you only buy from ebay store folks that part out bikes for their business with tons of feedback).
Use ONLY oem parts, especially electrical.
Ya need to check your plug at the rectifier to see if it's burned. With a multi-meter, check voltage with a multi-meter on the battery terminals. It should be 14vt +- very little, at 5000rpm. If its bouncing all over, or is way above 14vt (like 15-16vt) the regulator/rec is bad for sure.
 

·
Gambling every time u rid
Joined
·
81 Posts
Discussion Starter · #3 ·
Thanks man, I took your advice and found an ebay seller that was a bit more expensive than others but at least had some sort of return policy. I hope this takes care of it. I haven't even taken the fairings off yet. I rode 25 miles and she broke down 4 times...at 11pm....while it was raining...and both my headlights went out. Horrible night.
 

·
"The Dude abides .. "
Joined
·
4,719 Posts
if you are not getting 14vt at the battery terminals when holding 5000 rpm, you may have a stator issue. The fact that the lights went out would lead me to believe you have a lack of power, not an issue with it being regulated..
 
1 - 4 of 4 Posts
Top