Yamaha R6 Forum: YZF-R6 Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello, I'm new here. Just became a happy owner of 07 R6, very impulsive purchase but when I took a spin I knew I need it, I'm sure you all know what I mean. Anyway it had a straight pipe and was way too loud for me so bought a Scorpion slip on for this model, problem is I can't attach the bracket anywhere, side of my bike doesn't look like in a manual and actually it doesn't look like the one on pictures I found online. I am attaching picture to show you what I mean, right now I gangstered it our with zip ties, no hate please, but how can I do it long term?
Tire Wheel Automotive tire Automotive lighting Hood
 

·
nova r6
Joined
·
3,261 Posts
Someone changed those rearsets to something different I havent seen on the 3rd gens, maybe the spacing for the gen 2 mounts are the same and that is whats on there even though that doesnt look right as well. You need to get the proper footrest assemblies for both sides to have them the same and to have the exhaust hanger that is on the right footrest bracket. I attached an ebay link to what it is supposed to look like. I installed vortex rearsets on my 09 and I think I still have both sides at the house I will try and remember to check when I get home.

 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Someone changed those rearsets to something different I havent seen on the 3rd gens, maybe the spacing for the gen 2 mounts are the same and that is whats on there even though that doesnt look right as well. You need to get the proper footrest assemblies for both sides to have them the same and to have the exhaust hanger that is on the right footrest bracket. I attached an ebay link to what it is supposed to look like. I installed vortex rearsets on my 09 and I think I still have both sides at the house I will try and remember to check when I get home.

[/URL]

Yeah I heard that as well, it's definitely not stock, I figured how to mount it anyway though for now, I'll send a pic to ask if it works without causing any issues
 
1 - 4 of 4 Posts
Top