Yamaha R6 Forum: YZF-R6 Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Decided to change oil a few weeks ago and overfilled, from that day no matter what i do the bike is not performing the same.

I was reading the wrong service manual and overfilled my bike, i noticed it when i took it for a spin and found out what i did and took out the excess oil, it acted a little better but far from perfect, so i talked to a friend and he told me to change the spark plugs, which i did and also clean out the intake manifold and change the air filter.
This makes it a little better with the sound and all but still not performing.

The bike seems like there is a lot of power but the rpm/speed is not climbing as it use to, i have to change the gears earlier than i am use to doing and there seems to be a lot of vibration.
I always use 93 gas so that is not the problem.
Also to note the day i did the oil change i change the orientation of my two bros slip on which was rubbing on the frame, i am not sure if this has anything to do with it as the bike seems like is short of either air or fuel and i am on the 3rd air filter.

I need some help in getting this bike back to par without having to spend a lot of money as my budget is tight.

Thanks.
 

·
Registered
Joined
·
218 Posts
how much did you overfill it by? do you have a powercommander with the air filter and exhaust?
 

·
My R6 has returned!!
Joined
·
1,930 Posts
Have you checked your airbox? is there still any oil going in there? Overfilling can have relatively long lasting effects, but once remedied, the effects are not permanent. If the problem was cause from overfilling, then they'll slowly diminish if you've checked to make sure your airbox and plugs are pristine and you're no longer over filled, ride it a bit, then you're good to go in that department, may need to look elsewhere for the cause of the issue.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
The airbox is fine now and the filter i changed this weekend again. I have been riding it for almost 3 weeks and there is no change.
It will go fast but you have to ride in a higher gear than normal and it vibrates a little which is not normal.
Also the sound from the exhaust is not the same, i am not sure if this has anything with the Two bros slip on because i took it off and moved it on that same day.
 

·
Love to RIDE!
Joined
·
238 Posts
I am having a problem like the one you are having. I thought it was in the air and fuel but I had it checked yesterday and was near perfect. I'm going to check the TPS on the pciii today. I hope we can figure our problems out.
 

·
STOP PROJECTING ON [email protected]!!@
Joined
·
2,456 Posts
1/10th of a liter overfull r u kidding.. thats nothing. its something else. fuel pump? who knows.
 
1 - 10 of 10 Posts
Top