Yamaha R6 Forum: YZF-R6 Forums banner

321 - 335 of 335 Posts

·
Premium Member
Joined
·
30,463 Posts
Discussion Starter #321
giggity.

i truly wanna thank y'all for taking a shot on this product... those that have know it was worth every penny. i'm still kicking myself for waiting so long to install mine. SUCH a massive difference in time and mess when changing the oil.
 

·
Premium Member
Joined
·
30,463 Posts
Discussion Starter #323
one left in this batch... who wants it? trust me when i say, this is easily the best upgrade i did when it comes to simplifying a process.
 

·
Registered
Joined
·
32 Posts
Has anyone had issue of oil leaking from ball assembly? I had mine installed by motorcycle shop as oil pan needed to be replaced. Mine is leaking from ball assembly not from thread or sides.
 

Attachments

·
Registered
Joined
·
85 Posts
Has anyone had issue of oil leaking from ball assembly? I had mine installed by motorcycle shop as oil pan needed to be replaced. Mine is leaking from ball assembly not from thread or sides.
I haven't experienced this. Have you wiped the oil off to see if it comes back?
 

·
Registered
Joined
·
32 Posts
I haven't experienced this. Have you wiped the oil off to see if it comes back?
Yes i have tried that couple times. I also tried to pres ball to leak some oil and see it will sit better eventually but it hasn't help much with leak. It still leaks a little... I have also contacted Stahlbus and they sent replacement valve saying it was pressure tested. But the problem is still persistent. They say it could be viscosity of oil. I use Motul 7100 Synthetic Oil 4T - 10W40 which everybody seems to be using.

Any feedback is appreciated. I am glad that finally somebody replied to this post. Its been while since i posted my issue/question.
 

·
Registered
Joined
·
85 Posts
Yes i have tried that couple times. I also tried to pres ball to leak some oil and see it will sit better eventually but it hasn't help much with leak. It still leaks a little... I have also contacted Stahlbus and they sent replacement valve saying it was pressure tested. But the problem is still persistent. They say it could be viscosity of oil. I use Motul 7100 Synthetic Oil 4T - 10W40 which everybody seems to be using.

Any feedback is appreciated. I am glad that finally somebody replied to this post. Its been while since i posted my issue/question.
So you are using the replacement valve and it still leaks? As far as the viscosity of the oil, I'd imagine the less viscous (more fluid) oil would leak more. As far as motul oil goes, I usually see people running 300v 10w-40. That's what I'm running and I have no leaks.

Did you validate the bolt size and thread pitch before purchasing? (I doubt this is the issue as well, but just checking)
 

·
Registered
Joined
·
32 Posts
So you are using the replacement valve and it still leaks? As far as the viscosity of the oil, I'd imagine the less viscous (more fluid) oil would leak more. As far as motul oil goes, I usually see people running 300v 10w-40. That's what I'm running and I have no leaks.

Did you validate the bolt size and thread pitch before purchasing? (I doubt this is the issue as well, but just checking)
The bolt size is Thread M14 x 1.5. The worst part is it's leaking form inside (where ball is seated) and not from thread. You are absolutely right about viscosity as more viscous oil should leak less.
 

·
Premium Member
Joined
·
30,463 Posts
Discussion Starter #332
shoot me an email, and i'll forward it on to the manufacturer. they're in cali, so "state-side"... they're very good about figuring out issues - although quality control has never been one of those problems. [email protected]
 

·
I'm as hungry as my R6
Joined
·
25 Posts
Anyone have an updated link to where I can purchase this oil drain valve? I’ve searched for awhile and can’t seem to find one that isn’t a dead link.
 
321 - 335 of 335 Posts
Top