Yamaha R6 Forum: YZF-R6 Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
When I was riding one night I shut my bike off an the light would not turn back on. My buddy gave me a rectifier an it worked for a Lil while but now when I ride it will not keep battery charged. Even after a slow steady charge. My last ride I broke down on side of freeway on Bellevue an had to bump start it. Once started the bike would rev up than down rev up than down. It ran like that all the way to Renton. Pops up code 46
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #2 ·
Bike runs fine after slow steady charge for a good few hours . Than slowly I notice every time I start the bike the battery is dying. Bump start it an the bike will run but when I hold the throttle bout half way it goes vroom vroom vroom . Replaced rectifier. Didn't fix it.
 

·
Registered
Joined
·
44 Posts
Hi there,

Code 46 is improper voltage, either that is too much or too little

Grab yourself a multimeter, remove the seat, test the battery charge with the bike shut-off

It should be 13.X-12.X , now start the bike, it will drop then rise (atleast it should) to 14-14.3/14.5 (reving to 5-6k)

Does it hit 14.3-14.5V while reving?

I dont think it will , if it doenst, your stator is toasted .

If it goes ABOVE 14.5 (15-16-17) then your rectifier is toasted.

Both of them, triger the code 46.. so you have to grab the multimeter, and test.

If you find out that it´s the stator, (or the previous test point to a stator problem) you can then resistance test it, at the connection plug (comming from left-side engine cover) again with a multimeter, to double-check it´s bad
 
1 - 3 of 3 Posts
Top