Yamaha R6 Forum: YZF-R6 Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
94 Posts
Discussion Starter · #1 ·
So...did a track day, figured i would run some race gas to see 'if there was a diffrent'. Not really, not on the stock ECU since its tuned for pump gas.

SO, then, some one tells me "Hey, Leaded fuel are bad for Titanium Valves" SO now...I ran 3 tanks of mixed 2gal of 100 unleaded to 3gal of Leaded 110. Its what my brother brought to the track for his R1.

So how bad is it? Should I replace my Valves...they have 6,500 mi on them now. I know they 'were' good still around 16k. So, if any one has 'knowlege' of this, please tell me what to expect or if I am parinoid. Thanks...
 

·
Registered
Joined
·
181 Posts
Nothing to worry about. An R1 has Ti valves in it also. It mite not run any better with the race gas but its not gonna hurt the engine. The only thing it will do is clog the cat and shorten the life of the o2 sensor.
 

·
Registered
Joined
·
94 Posts
Discussion Starter · #3 ·
Yeah, went to Beach Yamaha today to talk to Gery, OLD mechanic for Yamaha.

Told me it was cool, prolonged use of the fuel could take the face off the Valves over time, but 'sounded' good for a R6 with 6k on her.

SO....stickin' with 91 for now.

My cat...yaaaaa....its commin off any who lol. O2 Sensor also...but why does it hurt those? Over heat?
 

·
Registered
Joined
·
94 Posts
Discussion Starter · #5 ·
I have VP 103 right now. But like I said before, its usless unless you have a PCIII. Actually loose HP over 96 octain with a PCIII. So, stick with premium till I do that.

Waste of race gas...lol
 
1 - 5 of 5 Posts
Top